summaryrefslogtreecommitdiffstats
path: root/package/python3/python3-3.3-004-no-import-when-cross-compiling.patch
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2012-11-07 05:01:21 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-08 00:10:23 +0100
commit03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a (patch)
tree6468647d08879169eaaf2bd2d61c64471f905b5a /package/python3/python3-3.3-004-no-import-when-cross-compiling.patch
parenta32fa707e5d79c92908bb81142b00afe81a3e3e2 (diff)
downloadbuildroot-novena-03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a.tar.gz
buildroot-novena-03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a.zip
Add python3 package
[Peter: s/python/python3/] Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python3/python3-3.3-004-no-import-when-cross-compiling.patch')
-rw-r--r--package/python3/python3-3.3-004-no-import-when-cross-compiling.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/package/python3/python3-3.3-004-no-import-when-cross-compiling.patch b/package/python3/python3-3.3-004-no-import-when-cross-compiling.patch
new file mode 100644
index 000000000..cd5a43747
--- /dev/null
+++ b/package/python3/python3-3.3-004-no-import-when-cross-compiling.patch
@@ -0,0 +1,27 @@
+Disable import check when cross-compiling
+
+Once Python has compiled an extension (i.e some C code, potentially
+linked to a library), it tries to import it. This cannot work in
+cross-compilation mode, so we just disable this check.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
+---
+ setup.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+Index: Python-3.3.0/setup.py
+===================================================================
+--- Python-3.3.0.orig/setup.py
++++ Python-3.3.0/setup.py
+@@ -318,6 +318,10 @@
+ self.announce('WARNING: skipping import check for Cygwin-based "%s"'
+ % ext.name)
+ return
++ if os.environ.get('CROSS_COMPILING') == 'yes':
++ self.announce('WARNING: skipping import check for cross compiled "%s"'
++ % ext.name)
++ return
+ ext_filename = os.path.join(
+ self.build_lib,
+ self.get_ext_filename(self.get_ext_fullname(ext.name)))