summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.4-002-cross-compile.patch
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@anandra.org>2010-12-10 23:05:39 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-01-25 08:56:20 +0100
commitd82df10e90ee9457ea0baba2d6a766149d4b7c38 (patch)
treec99a4dab60853a69a86061328c2ad965ef5aa226 /package/python/python-2.4-002-cross-compile.patch
parentafe54f1008dee29af6338d8766381aad9e2871bd (diff)
downloadbuildroot-novena-d82df10e90ee9457ea0baba2d6a766149d4b7c38.tar.gz
buildroot-novena-d82df10e90ee9457ea0baba2d6a766149d4b7c38.zip
python: Port the python2.4 patches to 2.7
Signed-off-by: Maxime Ripard <ripard@archos.com>
Diffstat (limited to 'package/python/python-2.4-002-cross-compile.patch')
-rw-r--r--package/python/python-2.4-002-cross-compile.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/package/python/python-2.4-002-cross-compile.patch b/package/python/python-2.4-002-cross-compile.patch
deleted file mode 100644
index 207335a5e..000000000
--- a/package/python/python-2.4-002-cross-compile.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- Python-2.4.2-001/setup.py 2007-01-23 16:18:37.000000000 +0100
-+++ Python-2.4.2/setup.py 2007-01-23 16:26:43.000000000 +0100
-@@ -239,7 +239,18 @@
- return sys.platform
-
- def detect_modules(self):
-- # Ensure that /usr/local is always used
-+ try:
-+ modules_include_dirs = os.environ["PYTHON_MODULES_INCLUDE"].split()
-+ except KeyError:
-+ modules_include_dirs = ['/usr/include']
-+ try:
-+ modules_lib_dirs = os.environ["PYTHON_MODULES_LIB"].split()
-+ except KeyError:
-+ modules_lib_dirs = ['/usr/lib']
-+ for dir in modules_include_dirs:
-+ add_dir_to_list(self.compiler.include_dirs, dir)
-+ for dir in modules_lib_dirs:
-+ add_dir_to_list(self.compiler.library_dirs, dir)
-
- # Add paths to popular package managers on OS X/darwin
- if sys.platform == "darwin":
-@@ -258,11 +269,8 @@
- # lib_dirs and inc_dirs are used to search for files;
- # if a file is found in one of those directories, it can
- # be assumed that no additional -I,-L directives are needed.
-- lib_dirs = self.compiler.library_dirs + [
-- '/lib64', '/usr/lib64',
-- '/lib', '/usr/lib',
-- ]
-- inc_dirs = self.compiler.include_dirs + ['/usr/include']
-+ lib_dirs = self.compiler.library_dirs
-+ inc_dirs = self.compiler.include_dirs
- exts = []
-
- platform = self.get_platform()