summaryrefslogtreecommitdiffstats
path: root/package/openobex/openobex.mk
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2013-03-11 18:58:39 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-13 23:32:46 +0100
commit04092fa3570f0315042327148a0fe62854fc8722 (patch)
tree5528499b3a42209fd0b673dea0ae1eb4c23984d6 /package/openobex/openobex.mk
parent402d1476f7159ab8055ec8b811b4fb5cd78b5609 (diff)
downloadbuildroot-novena-04092fa3570f0315042327148a0fe62854fc8722.tar.gz
buildroot-novena-04092fa3570f0315042327148a0fe62854fc8722.zip
openobex: new package
Cc: Julien Boibessot <julien.boibessot@armadeus.com> Cc: Eric Jarrige <eric.jarrige@armadeus.org> Signed-off-by: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openobex/openobex.mk')
-rw-r--r--package/openobex/openobex.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/openobex/openobex.mk b/package/openobex/openobex.mk
new file mode 100644
index 000000000..0fb4f6572
--- /dev/null
+++ b/package/openobex/openobex.mk
@@ -0,0 +1,38 @@
+#############################################################
+#
+# openobex
+#
+#############################################################
+
+OPENOBEX_VERSION = 1.5
+OPENOBEX_SITE = http://ftp.osuosl.org/pub/linux/bluetooth
+# Libraries seems to be released under LGPLv2.1+,
+# while other material is under GPLv2+.
+OPENOBEX_LICENSE = GPLv2+/LGPLv2.1+
+OPENOBEX_LICENSE_FILES = COPYING COPYING.LIB
+
+OPENOBEX_DEPENDENCIES = host-pkgconf
+OPENOBEX_AUTORECONF = YES
+OPENOBEX_INSTALL_STAGING = YES
+
+OPENOBEX_CONF_OPT += \
+ $(if $(BR2_ENABLE_DEBUG),--enable-debug) \
+ $(if $(BR2_PACKAGE_OPENOBEX_APPS),--enable-apps) \
+ $(if $(BR2_PACKAGE_OPENOBEX_SYSLOG),--enable-syslog) \
+ $(if $(BR2_PACKAGE_OPENOBEX_DUMP),--enable-dump)
+
+ifeq ($(BR2_PACKAGE_OPENOBEX_BLUEZ),y)
+OPENOBEX_DEPENDENCIES += bluez_utils
+OPENOBEX_CONF_OPT += --with-bluez=$(STAGING_DIR)
+else
+OPENOBEX_CONF_OPT += --disable-bluetooth
+endif
+
+ifeq ($(BR2_PACKAGE_OPENOBEX_LIBUSB),y)
+OPENOBEX_DEPENDENCIES += libusb
+OPENOBEX_CONF_OPT += --with-usb=$(STAGING_DIR)
+else
+OPENOBEX_CONF_OPT += --disable-usb
+endif
+
+$(eval $(autotools-package))