summaryrefslogtreecommitdiffstats
path: root/package/mysql_client/mysql_client-configure-ps-cache-check.patch
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-06-23 01:30:01 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-23 14:16:17 +0200
commitd9c38d615af90782d62839a7b7836a24698b6416 (patch)
tree997c96d91885877020271f9e2bfac14ab103f095 /package/mysql_client/mysql_client-configure-ps-cache-check.patch
parent6dca8af97798138e487dbd652e95f5b5a4a74945 (diff)
downloadbuildroot-novena-d9c38d615af90782d62839a7b7836a24698b6416.tar.gz
buildroot-novena-d9c38d615af90782d62839a7b7836a24698b6416.zip
mysql_client: security bump to version 5.1.63
Bump to version 5.1.63 to fix CVE-2012-2122 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/mysql_client/mysql_client-configure-ps-cache-check.patch')
-rw-r--r--package/mysql_client/mysql_client-configure-ps-cache-check.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/mysql_client/mysql_client-configure-ps-cache-check.patch b/package/mysql_client/mysql_client-configure-ps-cache-check.patch
new file mode 100644
index 000000000..336e80e0b
--- /dev/null
+++ b/package/mysql_client/mysql_client-configure-ps-cache-check.patch
@@ -0,0 +1,39 @@
+Patch borrowed from
+http://cgit.openembedded.org/cgit.cgi/openembedded/tree/recipes/mysql/files/configure-ps-cache-check.patch
+
+It allows to specify through ac_cv_FIND_PROC how ps should be used on
+the target to find the PID of a program.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ configure.in | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+Index: mysql-5.1.53/configure.in
+===================================================================
+--- mysql-5.1.53.orig/configure.in
++++ mysql-5.1.53/configure.in
+@@ -462,8 +462,8 @@
+ # then Make, then shell. The autoconf substitution uses single quotes, so
+ # no unprotected single quotes should appear in the expression.
+ AC_PATH_PROG(PS, ps, ps)
+-AC_MSG_CHECKING("how to check if pid exists")
+-PS=$ac_cv_path_PS
++AC_CACHE_CHECK([how to check if pid exists], [ac_cv_FIND_PROC],
++[
+ # Linux style
+ if $PS wwwp $$ 2> /dev/null | grep -- "$0" > /dev/null
+ then
+@@ -502,8 +502,9 @@
+ AC_MSG_ERROR([Could not find the right ps and/or grep switches. Which OS is this? See the Installation chapter in the Reference Manual.])
+ esac
+ fi
+-AC_SUBST(FIND_PROC)
+-AC_MSG_RESULT("$FIND_PROC")
++ac_cv_FIND_PROC="$FIND_PROC"
++])
++AC_SUBST([FIND_PROC], [$ac_cv_FIND_PROC])
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)