aboutsummaryrefslogtreecommitdiffstats
path: root/package/multimedia/tremor
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-12-04 00:02:01 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-08 21:48:46 +0100
commit1dc19c44570031e28ad40a46f4184c5860371eac (patch)
tree23ceb307c498d1f11334488e0c70d64b896972ea /package/multimedia/tremor
parent5c3817bb46d97bd9e93f1def2eb7f5efb5c16188 (diff)
downloadbuildroot-novena-1dc19c44570031e28ad40a46f4184c5860371eac.tar.gz
buildroot-novena-1dc19c44570031e28ad40a46f4184c5860371eac.zip
libvorbis: split tremor into its own package
This commit splits the Tremor fixed-point implementation out of the libvorbis package and creates a new package called 'tremor' for it. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/tremor')
-rw-r--r--package/multimedia/tremor/Config.in7
-rw-r--r--package/multimedia/tremor/tremor.mk31
2 files changed, 38 insertions, 0 deletions
diff --git a/package/multimedia/tremor/Config.in b/package/multimedia/tremor/Config.in
new file mode 100644
index 000000000..2e58e0985
--- /dev/null
+++ b/package/multimedia/tremor/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_TREMOR
+ bool "tremor (fixed point vorbis decoder)"
+ help
+ Tremor is a fixed point implementation of an Ogg Vorbis
+ decoder. It provides a decoding API similar to libvorbis,
+ but gives much better performance on systems without a
+ floating-point unit.
diff --git a/package/multimedia/tremor/tremor.mk b/package/multimedia/tremor/tremor.mk
new file mode 100644
index 000000000..b49337542
--- /dev/null
+++ b/package/multimedia/tremor/tremor.mk
@@ -0,0 +1,31 @@
+############################################################
+#
+# Tremor (Integer decoder for Vorbis)
+#
+############################################################
+
+TREMOR_TRUNK:=http://svn.xiph.org/trunk/Tremor/
+TREMOR_VERSION:=16259
+TREMOR_NAME:=Tremor-svn-r$(TREMOR_VERSION)
+TREMOR_DIR:=$(BUILD_DIR)/$(TREMOR_NAME)
+TREMOR_SOURCE:=$(TREMOR_NAME).tar.bz2
+TREMOR_CAT=$(BZCAT)
+TREMOR_AUTORECONF = YES
+TREMOR_INSTALL_STAGING = YES
+TREMOR_INSTALL_TARGET = YES
+
+$(DL_DIR)/$(TREMOR_SOURCE):
+ $(SVN_CO) -r $(TREMOR_VERSION) $(TREMOR_TRUNK) $(TREMOR_DIR)
+ tar -cv -C $(BUILD_DIR) $(TREMOR_NAME) | bzip2 - -c > $@
+
+$(eval $(call AUTOTARGETS,package/multimedia,tremor))
+
+
+############################################################
+#
+# Toplevel Makefile options
+#
+############################################################
+ifeq ($(BR2_PACKAGE_TREMOR),y)
+TARGETS+=tremor
+endif