summaryrefslogtreecommitdiffstats
path: root/package/mke2fs/mke2fs.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-11 20:42:52 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-11 20:42:52 +0000
commitaba5e68975c41d9ac3a35305ccc7dce5131d7731 (patch)
tree19931fcf7f0d88e84dd291e2bad1709c6b82eec4 /package/mke2fs/mke2fs.mk
parent8f144a058addd40f1fb83cef51028ee58ba7f125 (diff)
downloadbuildroot-novena-aba5e68975c41d9ac3a35305ccc7dce5131d7731.tar.gz
buildroot-novena-aba5e68975c41d9ac3a35305ccc7dce5131d7731.zip
remove 'mke2fs' and instead add the properly named 'e2fsprogs'
Diffstat (limited to 'package/mke2fs/mke2fs.mk')
-rw-r--r--package/mke2fs/mke2fs.mk82
1 files changed, 0 insertions, 82 deletions
diff --git a/package/mke2fs/mke2fs.mk b/package/mke2fs/mke2fs.mk
deleted file mode 100644
index af0621448..000000000
--- a/package/mke2fs/mke2fs.mk
+++ /dev/null
@@ -1,82 +0,0 @@
-#############################################################
-#
-# mke2fs
-#
-#############################################################
-MKE2FS_VER:=1.35
-MKE2FS_SOURCE:=e2fsprogs-$(MKE2FS_VER).tar.gz
-MKE2FS_SITE:=http://aleron.dl.sourceforge.net/sourceforge/e2fsprogs
-MKE2FS_DIR:=$(BUILD_DIR)/e2fsprogs-$(MKE2FS_VER)
-MKE2FS_CAT:=zcat
-MKE2FS_BINARY:=misc/mke2fs
-MKE2FS_TARGET_BINARY:=sbin/mke2fs
-
-$(DL_DIR)/$(MKE2FS_SOURCE):
- $(WGET) -P $(DL_DIR) $(MKE2FS_SITE)/$(MKE2FS_SOURCE)
-
-mke2fs-source: $(DL_DIR)/$(MKE2FS_SOURCE)
-
-$(MKE2FS_DIR)/.unpacked: $(DL_DIR)/$(MKE2FS_SOURCE)
- $(MKE2FS_CAT) $(DL_DIR)/$(MKE2FS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $(MKE2FS_DIR)/.unpacked
-
-$(MKE2FS_DIR)/.configured: $(MKE2FS_DIR)/.unpacked
- (cd $(MKE2FS_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --with-cc=$(TARGET_CC) \
- --with-linker=$(TARGET_CROSS)ld \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --disable-elf-shlibs --disable-swapfs \
- --disable-debugfs --disable-imager \
- --disable-resizer --disable-fsck \
- --without-catgets $(DISABLE_NLS) \
- );
- touch $(MKE2FS_DIR)/.configured
-
-$(MKE2FS_DIR)/$(MKE2FS_BINARY): $(MKE2FS_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(MKE2FS_DIR) \
- PROG_SUBDIRS=misc
- $(STRIP) $(MKE2FS_DIR)/misc/mke2fs $(MKE2FS_DIR)/misc/badblocks;
- touch -c $(MKE2FS_DIR)/misc/mke2fs
-
-$(TARGET_DIR)/$(MKE2FS_TARGET_BINARY): $(MKE2FS_DIR)/$(MKE2FS_BINARY)
- #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(MKE2FS_DIR) install
- #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
- # $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
- # Only install a few selected items...
- cp -dpf $(MKE2FS_DIR)/misc/mke2fs $(TARGET_DIR)/sbin/mke2fs;
- cp -dpf $(MKE2FS_DIR)/misc/badblocks $(TARGET_DIR)/sbin/badblocks;
- touch -c $(TARGET_DIR)/sbin/mke2fs
-
-mke2fs: uclibc $(TARGET_DIR)/$(MKE2FS_TARGET_BINARY)
-
-mke2fs-clean:
- #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(MKE2FS_DIR) uninstall
- rm -f $(TARGET_DIR)/sbin/mke2fs $(TARGET_DIR)/sbin/badblocks;
- -$(MAKE) -C $(MKE2FS_DIR) clean
-
-mke2fs-dirclean:
- rm -rf $(MKE2FS_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(strip $(BR2_PACKAGE_MKE2FS)),y)
-TARGETS+=mke2fs
-endif