aboutsummaryrefslogtreecommitdiffstats
path: root/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2012-12-30 12:17:46 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-01 22:19:11 +0100
commit3f538e53e1250263f7d2a3bc7d0f0c738265c940 (patch)
tree7e42f574077dce26374ab4bf4a439ceb68731ebd /package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
parentcf32809c5e04eb0fffa3edf0b8323c8ea0183b05 (diff)
downloadbuildroot-novena-3f538e53e1250263f7d2a3bc7d0f0c738265c940.tar.gz
buildroot-novena-3f538e53e1250263f7d2a3bc7d0f0c738265c940.zip
lttng-tools: bump to 2.1.0
* add patch adding src/bin/lttng-sessiond/lttng-ust-error.h which is missing in the lttng-tools-2.1.0 release tarball. * update the sync_file_range patch. Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch')
-rw-r--r--package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch51
1 files changed, 26 insertions, 25 deletions
diff --git a/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch b/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
index 3a1807ed5..fcaaa3e32 100644
--- a/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
+++ b/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
@@ -16,35 +16,36 @@ diff --git a/configure.ac b/configure.ac
index 5808c79..065b9cf 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -120,7 +120,7 @@ AS_IF([test "x$lttng_ust_support" = "xyes"], [
-
- AM_CONDITIONAL([HAVE_LIBLTTNG_UST_CTL], [ test "x$ac_cv_lib_lttng_ust_ctl_ustctl_create_session" = "xyes" ])
-
+@@ -150,7 +150,7 @@ AS_IF([test "x$lttng_ust_support" = "xyes"], [
+ )
+ ])
+ AM_CONDITIONAL([HAVE_LIBLTTNG_UST_CTL], [test "x$lttng_ust_ctl_found" = xyes])
-AC_CHECK_FUNCS([sched_getcpu sysconf])
+AC_CHECK_FUNCS([sched_getcpu sysconf sync_file_range])
-
+
# check for dlopen
AC_CHECK_LIB([dl], [dlopen],
-diff --git a/src/common/compat/fcntl.h b/src/common/compat/fcntl.h
-index 58c1579..dafb33e 100644
---- a/src/common/compat/fcntl.h
-+++ b/src/common/compat/fcntl.h
-@@ -23,10 +23,15 @@
-
- #ifdef __linux__
-
-+#if defined(HAVE_SYNC_FILE_RANGE)
- extern int compat_sync_file_range(int fd, off64_t offset, off64_t nbytes,
- unsigned int flags);
- #define lttng_sync_file_range(fd, offset, nbytes, flags) \
- compat_sync_file_range(fd, offset, nbytes, flags)
+@@ -394,4 +394,3 @@ AS_IF([test "x$consumerd_only" = "xno"],[
+ ])
+
+ AS_ECHO()
+-
+diff --git a/src/common/compat/compat-fcntl.c b/src/common/compat/compat-fcntl.c
+index 5a1c757..7ff63a3 100644
+--- a/src/common/compat/compat-fcntl.c
++++ b/src/common/compat/compat-fcntl.c
+@@ -23,7 +23,11 @@
+ int compat_sync_file_range(int fd, off64_t offset, off64_t nbytes,
+ unsigned int flags)
+ {
++#ifdef HAVE_SYNC_FILE_RANGE
+ return sync_file_range(fd, offset, nbytes, flags);
+#else
-+#define lttng_sync_file_range(fd, offset, nbytes, flags) \
-+ fdatasync(fd);
++ return fdatasync(fd);
+#endif
-
- #elif defined(__FreeBSD__)
-
---
-1.7.10
+ }
+
+ #endif /* __linux__ */
+--
+1.8.0.3