summaryrefslogtreecommitdiffstats
path: root/package/linux-pam/linux-pam-rhosts.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:33:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:59:03 +0200
commit32a0454d3c495b12824ef4a0d0341237302d148a (patch)
tree9acc870d089b0028cecdfb1846b828ae4bd38910 /package/linux-pam/linux-pam-rhosts.patch
parentf9686563b4fd3eed22e26105f7c440f0b74fcac1 (diff)
parentdafa32b3bd75e9d155d075c796fa5b0ecbb9b11b (diff)
downloadbuildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.tar.gz
buildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.zip
Merge branch 'next'
Conflicts: package/e2fsprogs/e2fsprogs.mk package/libfuse/libfuse.mk package/multimedia/mpd/mpd.mk package/smartmontools/smartmontools.mk Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/linux-pam/linux-pam-rhosts.patch')
-rw-r--r--package/linux-pam/linux-pam-rhosts.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/linux-pam/linux-pam-rhosts.patch b/package/linux-pam/linux-pam-rhosts.patch
new file mode 100644
index 000000000..58f9adbb1
--- /dev/null
+++ b/package/linux-pam/linux-pam-rhosts.patch
@@ -0,0 +1,24 @@
+Conditionally compile per ruserok availability
+
+ruserok is not available/functional in uclibc, provide conditions for compilation.
+
+Signed-off-by: Dmitry Golubovsky <golubovsky@gmail.com>
+
+Index: linux-pam-1.1.4/modules/pam_rhosts/pam_rhosts.c
+============================================================================
+--- linux-pam-1.1.4/modules/pam_rhosts/pam_rhosts.c 2011-06-21 05:04:56.000000000 -0400
++++ linux-pam-1.1.4/modules/pam_rhosts/pam_rhosts.c 2012-08-09 21:19:34.000000000 -0400
+@@ -114,8 +114,12 @@
+ #ifdef HAVE_RUSEROK_AF
+ retval = ruserok_af (rhost, as_root, ruser, luser, PF_UNSPEC);
+ #else
++ #ifdef HAVE_RUSEROK
+ retval = ruserok (rhost, as_root, ruser, luser);
+-#endif
++ #else
++ retval = -1;
++ #endif /* HAVE_RUSEROK */
++#endif /*HAVE_RUSEROK_AF */
+ if (retval != 0) {
+ if (!opt_silent || opt_debug)
+ pam_syslog(pamh, LOG_WARNING, "denied access to %s@%s as %s",