summaryrefslogtreecommitdiffstats
path: root/package/libxslt/libxslt.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-03-09 20:34:19 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-03-09 20:34:19 +0100
commit15ca4eabc16a302f38ba53ce97986668e243b835 (patch)
treef8684f7a9919cd32a32c4f567ea3c16c88103099 /package/libxslt/libxslt.mk
parent034b92c6855a917b99d1e37b1f5cdaefd3c4a594 (diff)
parentefeebdbd427906fecf404e9a71066398d144f082 (diff)
downloadbuildroot-novena-15ca4eabc16a302f38ba53ce97986668e243b835.tar.gz
buildroot-novena-15ca4eabc16a302f38ba53ce97986668e243b835.zip
Merge branch 'for-2011.05/remove-config-scripts' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/libxslt/libxslt.mk')
-rw-r--r--package/libxslt/libxslt.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libxslt/libxslt.mk b/package/libxslt/libxslt.mk
index 5fa2f4ce4..1efdcf8c2 100644
--- a/package/libxslt/libxslt.mk
+++ b/package/libxslt/libxslt.mk
@@ -39,5 +39,13 @@ endef
LIBXSLT_POST_INSTALL_STAGING_HOOKS += LIBXSLT_XSLT_CONFIG_FIXUP
+define LIBXSLT_REMOVE_CONFIG_SCRIPTS
+ $(RM) -f $(TARGET_DIR)/usr/bin/xslt-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+LIBXSLT_POST_INSTALL_TARGET_HOOKS += LIBXSLT_REMOVE_CONFIG_SCRIPTS
+endif
+
$(eval $(call AUTOTARGETS,package,libxslt))
$(eval $(call AUTOTARGETS,package,libxslt,host))