summaryrefslogtreecommitdiffstats
path: root/package/libtirpc/libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-11-10 11:42:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-14 22:58:17 +0100
commit18828103cdc8b929b29f5cbc27cd771ab1a26326 (patch)
tree7ac4af38f456d37d2117e41a1590e566b8d3f03c /package/libtirpc/libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch
parent9346b1b979edc6444ca8539aec9e1bac585e001f (diff)
downloadbuildroot-novena-18828103cdc8b929b29f5cbc27cd771ab1a26326.tar.gz
buildroot-novena-18828103cdc8b929b29f5cbc27cd771ab1a26326.zip
libtirpc: add patches to fix a number of issues
libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch fixes build failures like http://autobuild.buildroot.org/results/7a3a751fe02c639ca75c575ca7fe20a72372b8d6/build-end.log. libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch ensures that functions not implemented by libtirpc are not described in a header file. It also allows to remove those prototypes that were not matching the functions available in glibc or uClibc, causing mismatch in prototypes. libtirpc-0007-doc-Makefile.am-fix-out-of-tree-installation.patch is a minor fix. The following patches (8 to 9) allow libtirpc to provide sufficient things to be able to build rpcbind on top of it. All these patches have been submitted upstream on the libtirpc-devel@ mailing list. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libtirpc/libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch')
-rw-r--r--package/libtirpc/libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/package/libtirpc/libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch b/package/libtirpc/libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch
new file mode 100644
index 000000000..1fdc310ef
--- /dev/null
+++ b/package/libtirpc/libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch
@@ -0,0 +1,33 @@
+From 8e02780905a3e13405a5a1b9f5b2e77655d5c7fb Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Sat, 10 Nov 2012 00:05:23 +0100
+Subject: [PATCH] rpcent: remove prototypes of reentrant variants
+
+The reentrant variants of getrpcbynumber() and al. are not implemented
+by libtirpc, so there is no point in advertising them in this header
+file.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ tirpc/rpc/rpcent.h | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/tirpc/rpc/rpcent.h b/tirpc/rpc/rpcent.h
+index 120801d..45775ed 100644
+--- a/tirpc/rpc/rpcent.h
++++ b/tirpc/rpc/rpcent.h
+@@ -55,11 +55,6 @@ struct rpcent {
+ int r_number; /* rpc program number */
+ };
+
+-extern struct rpcent *getrpcbyname_r(const char *, struct rpcent *,
+- char *, int);
+-extern struct rpcent *getrpcbynumber_r(int, struct rpcent *, char *, int);
+-extern struct rpcent *getrpcent_r(struct rpcent *, char *, int);
+-
+ /* Old interfaces that return a pointer to a static area; MT-unsafe */
+ extern struct rpcent *getrpcbyname(const char *);
+ extern struct rpcent *getrpcbynumber(int);
+--
+1.7.9.5
+