summaryrefslogtreecommitdiffstats
path: root/package/libtirpc/libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-11-10 11:42:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-14 22:58:17 +0100
commit18828103cdc8b929b29f5cbc27cd771ab1a26326 (patch)
tree7ac4af38f456d37d2117e41a1590e566b8d3f03c /package/libtirpc/libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch
parent9346b1b979edc6444ca8539aec9e1bac585e001f (diff)
downloadbuildroot-novena-18828103cdc8b929b29f5cbc27cd771ab1a26326.tar.gz
buildroot-novena-18828103cdc8b929b29f5cbc27cd771ab1a26326.zip
libtirpc: add patches to fix a number of issues
libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch fixes build failures like http://autobuild.buildroot.org/results/7a3a751fe02c639ca75c575ca7fe20a72372b8d6/build-end.log. libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch ensures that functions not implemented by libtirpc are not described in a header file. It also allows to remove those prototypes that were not matching the functions available in glibc or uClibc, causing mismatch in prototypes. libtirpc-0007-doc-Makefile.am-fix-out-of-tree-installation.patch is a minor fix. The following patches (8 to 9) allow libtirpc to provide sufficient things to be able to build rpcbind on top of it. All these patches have been submitted upstream on the libtirpc-devel@ mailing list. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libtirpc/libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch')
-rw-r--r--package/libtirpc/libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/libtirpc/libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch b/package/libtirpc/libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch
new file mode 100644
index 000000000..b1865aee7
--- /dev/null
+++ b/package/libtirpc/libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch
@@ -0,0 +1,43 @@
+From 88147b753b86df7e7505ef8150f1329f7c6951cc Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Fri, 9 Nov 2012 19:37:24 +0100
+Subject: [PATCH] rpcent: mark getrpcbyname name argument as const char *
+
+This allows to match the glibc prototype and avoid compiling error
+when building libtirpc against a C library that has RPC support.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ src/getrpcent.c | 2 +-
+ tirpc/rpc/rpcent.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/getrpcent.c b/src/getrpcent.c
+index 645f18f..1b54b6d 100644
+--- a/src/getrpcent.c
++++ b/src/getrpcent.c
+@@ -138,7 +138,7 @@ no_yp:
+
+ struct rpcent *
+ getrpcbyname(name)
+- char *name;
++ const char *name;
+ {
+ struct rpcent *rpc = NULL;
+ char **rp;
+diff --git a/tirpc/rpc/rpcent.h b/tirpc/rpc/rpcent.h
+index 8ce05ed..120801d 100644
+--- a/tirpc/rpc/rpcent.h
++++ b/tirpc/rpc/rpcent.h
+@@ -61,7 +61,7 @@ extern struct rpcent *getrpcbynumber_r(int, struct rpcent *, char *, int);
+ extern struct rpcent *getrpcent_r(struct rpcent *, char *, int);
+
+ /* Old interfaces that return a pointer to a static area; MT-unsafe */
+-extern struct rpcent *getrpcbyname(char *);
++extern struct rpcent *getrpcbyname(const char *);
+ extern struct rpcent *getrpcbynumber(int);
+ extern struct rpcent *getrpcent(void);
+ #endif
+--
+1.7.9.5
+