summaryrefslogtreecommitdiffstats
path: root/package/gdisk/gdisk.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-07 10:45:24 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-10 22:06:54 +0100
commit29b83f05274d312a0088dcfdfd52fffb65f64422 (patch)
treed79a24f85922b4484868c5d11edadd6bed51d4ca /package/gdisk/gdisk.mk
parent7cbb30115b0c0e70e298c4f0c7b048c396db46b0 (diff)
downloadbuildroot-novena-29b83f05274d312a0088dcfdfd52fffb65f64422.tar.gz
buildroot-novena-29b83f05274d312a0088dcfdfd52fffb65f64422.zip
gdisk: rename to gptfdisk
In order to match the new upstream name, rename the gdisk package to gptfdisk. We add the relevant legacy configuration options to ensure a smooth transition for users. [Peter: fixup Config.in indentation] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gdisk/gdisk.mk')
-rw-r--r--package/gdisk/gdisk.mk39
1 files changed, 0 insertions, 39 deletions
diff --git a/package/gdisk/gdisk.mk b/package/gdisk/gdisk.mk
deleted file mode 100644
index cda369ede..000000000
--- a/package/gdisk/gdisk.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-#############################################################
-#
-# gdisk
-#
-#############################################################
-
-GDISK_VERSION = 0.8.6
-GDISK_SITE = http://downloads.sourceforge.net/sourceforge/gptfdisk
-GDISK_SOURCE = gptfdisk-$(GDISK_VERSION).tar.gz
-
-GDISK_TARGETS_$(BR2_PACKAGE_GDISK_GDISK) += gdisk
-GDISK_TARGETS_$(BR2_PACKAGE_GDISK_SGDISK) += sgdisk
-
-ifneq ($(GDISK_TARGETS_y),)
-
-GDISK_DEPENDENCIES += util-linux
-ifeq ($(BR2_PACKAGE_GDISK_SGDISK),y)
- GDISK_DEPENDENCIES += popt
-endif
-
-
-define GDISK_BUILD_CMDS
- $(TARGET_CONFIGURE_OPTS) $(MAKE) CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" \
- -C $(@D) $(GDISK_TARGETS_y)
-endef
-
-define GDISK_INSTALL_TARGET_CMDS
- for i in $(GDISK_TARGETS_y); do \
- $(INSTALL) -D $(@D)/$$i $(TARGET_DIR)/usr/sbin/; \
- done
-endef
-
-define GDISK_UNINSTALL_TARGET_CMDS
- rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,$(GDISK_TARGETS_y))
-endef
-
-endif
-
-$(eval $(generic-package))