aboutsummaryrefslogtreecommitdiffstats
path: root/package/games/lxdoom/lxdoom.mk
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
commit1b5c1e7bdbdf496078a8556c2906919432f60d52 (patch)
tree0eb0f404efb85594de1dfb4e3d31856d04808faf /package/games/lxdoom/lxdoom.mk
parent022b95d6ef7b303f6fbd48c220001674eec4717a (diff)
downloadbuildroot-novena-1b5c1e7bdbdf496078a8556c2906919432f60d52.tar.gz
buildroot-novena-1b5c1e7bdbdf496078a8556c2906919432f60d52.zip
games: Move all games into games subdir
Moved all games into a subdir called games and then updated makefiles as necessary. If not one objects to this one then I will probably do the same for audio next. Daniel Laird
Diffstat (limited to 'package/games/lxdoom/lxdoom.mk')
-rw-r--r--package/games/lxdoom/lxdoom.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/games/lxdoom/lxdoom.mk b/package/games/lxdoom/lxdoom.mk
new file mode 100644
index 000000000..71d36f498
--- /dev/null
+++ b/package/games/lxdoom/lxdoom.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# lxdoom
+#
+#############################################################
+LXDOOM_VERSION = 1.4.4
+LXDOOM_SOURCE = lxdoom-$(LXDOOM_VERSION).tar.gz
+LXDOOM_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/lxdoom
+LXDOOM_INSTALL_STAGING = NO
+LXDOOM_INSTALL_TARGET = YES
+LXDOOM_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
+
+LXDOOM_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) --prefix=/usr \
+ --includedir=/usr/include --enable-shared \
+ $(DISABLE_NLS)
+
+LXDOOM_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package/games,lxdoom))