summaryrefslogtreecommitdiffstats
path: root/package/firmware-imx/firmware-imx.mk
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-12-19 13:37:33 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-14 15:04:05 +0100
commit22001201ded95850f0f9388f26333c077230b6c6 (patch)
treee194ebdb02384b08dbc4ac35f87386b7afefd49d /package/firmware-imx/firmware-imx.mk
parent85bd7b910c060b1a9649f6cb1b0eec7db04b94b3 (diff)
downloadbuildroot-novena-22001201ded95850f0f9388f26333c077230b6c6.tar.gz
buildroot-novena-22001201ded95850f0f9388f26333c077230b6c6.zip
firmware-imx: new package
[Peter: ensure lib/firmware exists, move under 'Misc devices firmware'] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/firmware-imx/firmware-imx.mk')
-rw-r--r--package/firmware-imx/firmware-imx.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/firmware-imx/firmware-imx.mk b/package/firmware-imx/firmware-imx.mk
new file mode 100644
index 000000000..3b43bef5c
--- /dev/null
+++ b/package/firmware-imx/firmware-imx.mk
@@ -0,0 +1,39 @@
+#############################################################
+#
+# buildroot makefile for firmware-imx
+#
+#############################################################
+
+FIRMWARE_IMX_VERSION = 12.09.01
+# No official download site from freescale, just this mirror
+FIRMWARE_IMX_SITE = http://download.ossystems.com.br/bsp/freescale/source
+FIRMWARE_IMX_SOURCE = firmware-imx-$(FIRMWARE_IMX_VERSION).bin
+FIRMWARE_IMX_LICENSE = Freescale Semiconductor Software License Agreement, \
+ Atheros license (ath6k)
+FIRMWARE_IMX_LICENSE_FILES = licenses/vpu/EULA licenses/ath6k/AR6102/License.txt
+# This is a legal minefield: the EULA specifies that
+# the Board Support Package includes software and hardware (sic!)
+# for which a separate license is needed...
+FIRMWARE_IMX_REDISTRIBUTE = NO
+
+FIRMWARE_IMX_BLOBS = ath6k sdma vpu
+
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (firmware-imx-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+# The --auto-accept skips the license check - not needed for us
+# because we have legal-info.
+define FIRMWARE_IMX_EXTRACT_CMDS
+ cd $(BUILD_DIR); \
+ sh $(DL_DIR)/$(FIRMWARE_IMX_SOURCE) --force --auto-accept
+endef
+
+
+define FIRMWARE_IMX_INSTALL_TARGET_CMDS
+ mkdir -p $(TARGET_DIR)/lib/firmware
+ for blobdir in $(FIRMWARE_IMX_BLOBS); do \
+ cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware; \
+ done
+endef
+
+$(eval $(generic-package))