summaryrefslogtreecommitdiffstats
path: root/package/fb-test-app/fb-test-app-override-cflags.patch
diff options
context:
space:
mode:
authorLudovic Desroches <ludovic.desroches@atmel.com>2012-10-09 05:53:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-10 14:44:34 +0200
commitbbfa50f3ead1f19e4d0bb9dcb7364d58225be139 (patch)
tree5d36344882385a9cd96b3a2264ce28611a32889d /package/fb-test-app/fb-test-app-override-cflags.patch
parent7d9dfd817012090bb2753c7a3dee94ff1d2e0027 (diff)
downloadbuildroot-novena-bbfa50f3ead1f19e4d0bb9dcb7364d58225be139.tar.gz
buildroot-novena-bbfa50f3ead1f19e4d0bb9dcb7364d58225be139.zip
fb-test-app: new package
Test suite for Linux framebuffer. [Peter: add patch to build with our TARGET_CFLAGS] Signed-off-by: Ludovic Desroches <ludovic.desroches@atmel.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fb-test-app/fb-test-app-override-cflags.patch')
-rw-r--r--package/fb-test-app/fb-test-app-override-cflags.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/fb-test-app/fb-test-app-override-cflags.patch b/package/fb-test-app/fb-test-app-override-cflags.patch
new file mode 100644
index 000000000..550ca6ed8
--- /dev/null
+++ b/package/fb-test-app/fb-test-app-override-cflags.patch
@@ -0,0 +1,35 @@
+From deb5143e8e4580d7767de59a2e983dda262b0669 Mon Sep 17 00:00:00 2001
+From: Peter Korsgaard <jacmet@sunsite.dk>
+Date: Wed, 10 Oct 2012 14:38:13 +0200
+Subject: [PATCH] allow custom CFLAGS to passed on the make command line
+
+Ensure the required CFLAGS are appended to what is provided on the
+command line.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ Makefile | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 057d539..c3102ea 100644
+--- a/Makefile
++++ b/Makefile
+@@ -11,10 +11,10 @@ else
+ CFLAGS=-O2 -Wall
+ endif
+
+-CFLAGS += -DVERSION=$(VERSION)
+-CFLAGS += -DPATCHLEVEL=$(PATCHLEVEL)
+-CFLAGS += -DSUBLEVEL=$(SUBLEVEL)
+-CFLAGS += -DVERSION_NAME=\"$(NAME)\"
++override CFLAGS += -DVERSION=$(VERSION)
++override CFLAGS += -DPATCHLEVEL=$(PATCHLEVEL)
++override CFLAGS += -DSUBLEVEL=$(SUBLEVEL)
++override CFLAGS += -DVERSION_NAME=\"$(NAME)\"
+
+ PROGS=perf rect fb-test offset
+
+--
+1.7.10.4
+