summaryrefslogtreecommitdiffstats
path: root/package/elfutils/elfutils.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-06 05:22:49 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-07 21:43:01 +0100
commit8e6c06fb11684ab8aa5454338024040dae95e57e (patch)
treed2e7f9fd161131f6878c335693e642eb6b487ef8 /package/elfutils/elfutils.mk
parenteb6cf3003366864aa29cc56eab88c26c3d8baedf (diff)
downloadbuildroot-novena-8e6c06fb11684ab8aa5454338024040dae95e57e.tar.gz
buildroot-novena-8e6c06fb11684ab8aa5454338024040dae95e57e.zip
elfutils: towards uClibc support: argp-standalone usage
elfutils uses the argp family of functions, that isn't available in uClibc. So, we add a dependency on argp-standalone if building with uClibc, and modify elfutils source code to link against argp if needed. Heavily based from work done by Stefan Fröberg, but with many further modifications by Thomas Petazzoni. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/elfutils/elfutils.mk')
-rw-r--r--package/elfutils/elfutils.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
index f8a4e85da..9f9de52ef 100644
--- a/package/elfutils/elfutils.mk
+++ b/package/elfutils/elfutils.mk
@@ -25,6 +25,10 @@ ELFUTILS_CONF_ENV += \
CPPFLAGS="$(filter-out -D_FILE_OFFSET_BITS=64,$(TARGET_CPPFLAGS))"
endif
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)
+ ELFUTILS_DEPENDENCIES += argp-standalone
+endif
+
ifeq ($(BR2_PACKAGE_ZLIB),y)
ELFUTILS_DEPENDENCIES += zlib
ELFUTILS_CONF_OPT += --with-zlib