aboutsummaryrefslogtreecommitdiffstats
path: root/package/binutils/binutils.mk
diff options
context:
space:
mode:
authorMischa Jonker <mischa.jonker@synopsys.com>2013-05-02 09:51:25 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-04 23:07:44 +0200
commitd81457eaed604b21dcfb85d167683f69cfb47c53 (patch)
tree264dbd9d60abd85692588611206d0fa5399783d2 /package/binutils/binutils.mk
parent1445b7fd2e46db5d39ad5e2f5cc262574399f5f3 (diff)
downloadbuildroot-novena-d81457eaed604b21dcfb85d167683f69cfb47c53.tar.gz
buildroot-novena-d81457eaed604b21dcfb85d167683f69cfb47c53.zip
arc: Add support for ARC-specific binutils
ARC support is not upstream yet. Signed-off-by: Mischa Jonker <mjonker@synopsys.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/binutils/binutils.mk')
-rw-r--r--package/binutils/binutils.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 92e0a7483..081be6ad4 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -26,6 +26,9 @@ BINUTILS_SITE = $(BR2_GNU_MIRROR)/binutils
ifeq ($(ARCH),avr32)
BINUTILS_SITE = ftp://www.at91.com/pub/buildroot
endif
+ifeq ($(BR2_arc),y)
+BINUTILS_SITE = $(BR2_ARC_SITE)
+endif
BINUTILS_EXTRA_CONFIG_OPTIONS = $(call qstrip,$(BR2_BINUTILS_EXTRA_CONFIG_OPTIONS))
BINUTILS_INSTALL_STAGING = YES
BINUTILS_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
@@ -52,7 +55,11 @@ HOST_BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
--with-sysroot=$(STAGING_DIR) \
$(BINUTILS_EXTRA_CONFIG_OPTIONS)
+ifeq ($(BINUTILS_VERSION),2.19-arc)
+HOST_BINUTILS_DEPENDENCIES = host-flex host-bison
+else
HOST_BINUTILS_DEPENDENCIES =
+endif
# We just want libbfd and libiberty, not the full-blown binutils in staging
define BINUTILS_INSTALL_STAGING_CMDS