summaryrefslogtreecommitdiffstats
path: root/package/aumix
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-09-05 12:06:50 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-09-05 12:06:50 +0000
commit76235a15b37bae9e3c83bc20e9afd49a66e33455 (patch)
tree82f014617a2c1149231675eddd72714d6f7bd659 /package/aumix
parent03e3886c012c889611b77df85c5491989c4ebc31 (diff)
downloadbuildroot-novena-76235a15b37bae9e3c83bc20e9afd49a66e33455.tar.gz
buildroot-novena-76235a15b37bae9e3c83bc20e9afd49a66e33455.zip
audio: Move all audio packages into audio subdir
Moved all audio packages into a subdir called audio. I then created a Config.in and made sure that a audio.mk existed. Daniel Laird
Diffstat (limited to 'package/aumix')
-rw-r--r--package/aumix/Config.in12
-rw-r--r--package/aumix/aumix.mk64
2 files changed, 0 insertions, 76 deletions
diff --git a/package/aumix/Config.in b/package/aumix/Config.in
deleted file mode 100644
index 3d3208250..000000000
--- a/package/aumix/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config BR2_PACKAGE_AUMIX
- bool "aumix"
- select BR2_PACKAGE_NCURSES
- help
- aumix is a small, easy-to-use program to control the mixer
- of your sound card. It runs in text mode using the ncurses
- library, or from the command line (non-interactively).
- It can read default settings from a file, and it can also
- automatically save and restore the mixer settings at shutdown
- and boot.
-
- http://jpj.net/~trevor/aumix.html
diff --git a/package/aumix/aumix.mk b/package/aumix/aumix.mk
deleted file mode 100644
index d30b3a7be..000000000
--- a/package/aumix/aumix.mk
+++ /dev/null
@@ -1,64 +0,0 @@
-#############################################################
-#
-# aumix
-#
-#############################################################
-
-AUMIX_VERSION=2.8
-AUMIX_SOURCE=aumix-$(AUMIX_VERSION).tar.bz2
-AUMIX_SITE=http://jpj.net/~trevor/aumix
-AUMIX_DIR=$(BUILD_DIR)/aumix-$(AUMIX_VERSION)
-AUMIX_CAT:=$(BZCAT)
-
-$(DL_DIR)/$(AUMIX_SOURCE):
- $(WGET) -P $(DL_DIR) $(AUMIX_SITE)/$(AUMIX_SOURCE)
-
-$(AUMIX_DIR)/.unpacked: $(DL_DIR)/$(AUMIX_SOURCE)
- $(AUMIX_CAT) $(DL_DIR)/$(AUMIX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $@
-
-$(AUMIX_DIR)/.configured: $(AUMIX_DIR)/.unpacked
- (cd $(AUMIX_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- $(TARGET_CONFIGURE_ARGS) \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libdir=$(STAGING_DIR)/lib \
- --includedir=$(STAGING_DIR)/usr/include \
- --without-gtk \
- --without-gtk1 \
- --without-alsa \
- --without-gpm \
- --without-sysmouse \
- $(DISABLE_NLS) \
- )
- touch $@
-
-$(AUMIX_DIR)/src/aumix: $(AUMIX_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(AUMIX_DIR)
-
-$(AUMIX_DIR)/.installed: $(AUMIX_DIR)/src/aumix
- $(MAKE) -C $(AUMIX_DIR) DESTDIR=$(TARGET_DIR) install
- touch $@
-
-aumix: uclibc ncurses $(AUMIX_DIR)/.installed
-
-aumix-source: $(DL_DIR)/$(AUMIX_SOURCE)
-
-aumix-clean:
- -$(MAKE) -C $(AUMIX_DIR) clean
-
-aumix-dirclean:
- rm -rf $(AUMIX_DIR)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(strip $(BR2_PACKAGE_AUMIX)),y)
-TARGETS+=aumix
-endif