summaryrefslogtreecommitdiffstats
path: root/package/audio/festival/speech-tools
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-09-05 12:06:50 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-09-05 12:06:50 +0000
commit76235a15b37bae9e3c83bc20e9afd49a66e33455 (patch)
tree82f014617a2c1149231675eddd72714d6f7bd659 /package/audio/festival/speech-tools
parent03e3886c012c889611b77df85c5491989c4ebc31 (diff)
downloadbuildroot-novena-76235a15b37bae9e3c83bc20e9afd49a66e33455.tar.gz
buildroot-novena-76235a15b37bae9e3c83bc20e9afd49a66e33455.zip
audio: Move all audio packages into audio subdir
Moved all audio packages into a subdir called audio. I then created a Config.in and made sure that a audio.mk existed. Daniel Laird
Diffstat (limited to 'package/audio/festival/speech-tools')
-rw-r--r--package/audio/festival/speech-tools/Config.in6
-rw-r--r--package/audio/festival/speech-tools/speech-tools-1.2.96-beta-install.patch47
-rw-r--r--package/audio/festival/speech-tools/speech-tools.mk20
3 files changed, 73 insertions, 0 deletions
diff --git a/package/audio/festival/speech-tools/Config.in b/package/audio/festival/speech-tools/Config.in
new file mode 100644
index 000000000..d8405bad3
--- /dev/null
+++ b/package/audio/festival/speech-tools/Config.in
@@ -0,0 +1,6 @@
+ config BR2_PACKAGE_SPEECH_TOOLS
+ bool "speech tools for festival"
+ help
+ Speech tools for the festival text to speech system
+
+ http://festvox.org/packed/festival/latest
diff --git a/package/audio/festival/speech-tools/speech-tools-1.2.96-beta-install.patch b/package/audio/festival/speech-tools/speech-tools-1.2.96-beta-install.patch
new file mode 100644
index 000000000..3cc47d344
--- /dev/null
+++ b/package/audio/festival/speech-tools/speech-tools-1.2.96-beta-install.patch
@@ -0,0 +1,47 @@
+--- a/config/rules/install.mak 2001-04-04 07:55:32.000000000 -0400
++++ b/config/rules/install.mak 2008-04-03 12:37:45.000000000 -0400
+@@ -50,9 +50,9 @@ ifneq ($(SHARED),0)
+ endif
+ endif
+
+-ifeq ($(PROJECT_HOME_PATH), $(PROJECT_TOP_PATH))
+- TO_INSTALL=make_bin
+-else
++#ifeq ($(PROJECT_HOME_PATH), $(PROJECT_TOP_PATH))
++# TO_INSTALL=make_bin
++#else
+
+ TO_INSTALL= \
+ make_installed_exec$(S) \
+@@ -62,7 +62,7 @@ else
+ INSTALLED_LIB=$(shell (cd $($(PROJECT_PREFIX)_HOME); pwd))/lib
+ INSTALLED_PRIVATE_LIB=$(INSTALLED_LIB)/$(shell echo $(PROJECT_PREFIX)| tr A-Z a-z)
+ INSTALLED_BIN=$(shell (cd $($(PROJECT_PREFIX)_HOME); pwd))/bin
+-endif
++#endif
+
+ install: $(TO_INSTALL)
+
+--- a/config/rules/bin_process.mak 2004-01-27 18:56:39.000000000 -0500
++++ b/config/rules/bin_process.mak 2008-04-03 12:37:31.000000000 -0400
+@@ -69,10 +69,17 @@ endif
+ do \
+ b=`basename "$$i"`;\
+ $(ECHO_N) " $$b";\
+- $(INSTALL_PROG) -s "$$main/$$i" "$(subst TOP,$(TOP),$(BIN))/$$b";\
++ $(INSTALL_PROG) "$$main/$$i" "$(DESTDIR)/usr/bin/$$b";\
++ $(STRIP) "$(DESTDIR)/usr/bin/$$b";\
+ done
+- @echo
+-
++ @$(ECHO_N) "Install Scheme Libraries:"
++ @main=`pwd` ;\
++ mkdir -p "$(DESTDIR)/usr/share/festival"; cp -a "$$main/../../lib" "$(DESTDIR)/usr/share/festival";\
++ for i in `find "$(DESTDIR)/usr/share/festival/lib" -name Makefile`;\
++ do \
++ rm "$$i"; \
++ done
++
+ .link_main:
+ @$(MAKE) MADE_FROM_ABOVE=1 --no-print-directory -C '$(PROJECT_MAIN_DIR)' BIN=TOP/$(DIRNAME) LIBDIR=MAIN/TOP/$(PROJECT_LIBRARY_DIR) MAIN='$($(PROJECT_PREFIX)_HOME)' .link_main$(S)
+
diff --git a/package/audio/festival/speech-tools/speech-tools.mk b/package/audio/festival/speech-tools/speech-tools.mk
new file mode 100644
index 000000000..3f2ba090f
--- /dev/null
+++ b/package/audio/festival/speech-tools/speech-tools.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# speech-tools
+#
+#############################################################
+SPEECH_TOOLS_VERSION = 1.2.96-beta
+SPEECH_TOOLS_SOURCE = speech_tools-$(SPEECH_TOOLS_VERSION).tar.gz
+SPEECH_TOOLS_SITE = http://festvox.org/packed/festival/1.96
+SPEECH_TOOLS_AUTORECONF = NO
+SPEECH_TOOLS_INSTALL_STAGING = NO
+SPEECH_TOOLS_INSTALL_TARGET = YES
+SPEECH_TOOLS_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) STRIP=$(TARGET_STRIP) install
+
+SPEECH_TOOLS_CONF_OPT =
+SPEECH_TOOLS_MAKE_OPT = CC=$(TARGET_CC) CXX=$(TARGET_CXX)
+
+SPEECH_TOOLS_DEPENDENCIES = uclibc ncurses
+
+$(eval $(call AUTOTARGETS,package/festival,speech-tools))
+