summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-01 21:20:35 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-01 21:20:35 +0000
commit69f8592407635cc7b36aebac692e24a02b046aab (patch)
tree45744fac12f296318e2bbf7e234b6a58fb0da9f3 /package/Makefile.in
parentae6011eb3360be00b2c72b98faea6398c418770a (diff)
downloadbuildroot-novena-69f8592407635cc7b36aebac692e24a02b046aab.tar.gz
buildroot-novena-69f8592407635cc7b36aebac692e24a02b046aab.zip
buildroot: set SHELL instead of messing around with CONFIG_SHELL
Simply set SHELL to bash instead of adding CONFIG_SHELL to all shell invocations. CONFIG_SHELL is still set, as it is used by kconfig.
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index ca6dd1498..186329cf1 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -4,7 +4,7 @@ endif
ifndef HOSTMAKE
HOSTMAKE=$(MAKE)
endif
-HOSTMAKE :=$(shell $(CONFIG_SHELL) -c "which $(HOSTMAKE)" || type -p $(HOSTMAKE) || echo make)
+HOSTMAKE :=$(shell which $(HOSTMAKE) || type -p $(HOSTMAKE) || echo make)
MAKE1:=$(HOSTMAKE) -j1
MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
@@ -178,8 +178,8 @@ TARGET_STRIP=true -Not_stripping
STRIPCMD=$(TARGET_STRIP)
endif
INSTALL=/usr/bin/install
-FLEX:=$(shell $(CONFIG_SHELL) -c 'which flex || type -p flex')
-BISON:=$(shell $(CONFIG_SHELL) -c 'which bison || type -p bison')
+FLEX:=$(shell which flex || type -p flex)
+BISON:=$(shell which bison || type -p bison)
HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-e 's/sparc.*/sparc/' \