aboutsummaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-11-21 09:04:50 +0000
committerEric Andersen <andersen@codepoet.org>2002-11-21 09:04:50 +0000
commit7794775aa48350a61b4c7851a0fc9d701bbd6cd6 (patch)
tree53579923529e6c7db128044eb1fe4b9f1c535b11 /make
parent7b3014ef3f4c48af5f1002a5797c6878f1682fc6 (diff)
downloadbuildroot-novena-7794775aa48350a61b4c7851a0fc9d701bbd6cd6.tar.gz
buildroot-novena-7794775aa48350a61b4c7851a0fc9d701bbd6cd6.zip
Be even more careful -- avoid using 'which'
Diffstat (limited to 'make')
-rw-r--r--make/uclibc_toolchain.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index ba7cb4f0f..00320a81b 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -241,6 +241,8 @@ $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked
perl -i -p -e 's,^SYSTEM_DEVEL_PREFIX=.*,SYSTEM_DEVEL_PREFIX=\"$(STAGING_DIR)\",g' $(UCLIBC_DIR)/.config
perl -i -p -e 's,^DEVEL_TOOL_PREFIX=.*,DEVEL_TOOL_PREFIX=\"$(STAGING_DIR)/usr\",g' $(UCLIBC_DIR)/.config
perl -i -p -e 's,^SHARED_LIB_LOADER_PATH=.*,SHARED_LIB_LOADER_PATH=\"/lib\",g' $(UCLIBC_DIR)/.config
+ perl -i -p -e 's,^GCC_BIN=.*,GCC_BIN=$(STAGING_DIR)/bin/$(ARCH)-uclibc-gcc,g' $(UCLIBC_DIR)/extra/gcc-uClibc/Makefile
+ perl -i -p -e 's,^LD_BIN=.*,LD_BIN=$(STAGING_DIR)/bin/$(ARCH)-uclibc-ld,g' $(UCLIBC_DIR)/extra/gcc-uClibc/Makefile
$(MAKE) -C $(UCLIBC_DIR) oldconfig
# Note that since the target compiler does not yet exist, we will not
# be able to properly generate include/bits/syscall.h so we will need