aboutsummaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-09-04 23:48:03 +0000
committerEric Andersen <andersen@codepoet.org>2003-09-04 23:48:03 +0000
commit2279207edd36533f87c1067c474cf200fa585068 (patch)
tree54e15a7f704d5ee401163fd21f05004f20e1b216 /make
parentfba6a22e57ca4ba41a3d8ed488238c31332f0fd8 (diff)
downloadbuildroot-novena-2279207edd36533f87c1067c474cf200fa585068.tar.gz
buildroot-novena-2279207edd36533f87c1067c474cf200fa585068.zip
Make some more things compile
Diffstat (limited to 'make')
-rw-r--r--make/bridge.mk19
-rw-r--r--make/iptables.mk2
2 files changed, 17 insertions, 4 deletions
diff --git a/make/bridge.mk b/make/bridge.mk
index b26726a3e..0ecfa9c21 100644
--- a/make/bridge.mk
+++ b/make/bridge.mk
@@ -19,14 +19,27 @@ $(BRIDGE_BUILD_DIR)/.unpacked: $(DL_DIR)/$(BRIDGE_SOURCE)
$(BRIDGE_BUILD_DIR)/.configured: $(BRIDGE_BUILD_DIR)/.unpacked
(cd $(BRIDGE_BUILD_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
- ./configure \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ $(DISABLE_NLS) \
--with-linux-headers=$(BUILD_DIR)/linux \
);
-
touch $(BRIDGE_BUILD_DIR)/.configured
$(BRIDGE_BUILD_DIR)/brctl/brctl: $(BRIDGE_BUILD_DIR)/.configured
- $(MAKE) -C $(BRIDGE_BUILD_DIR) CC=$(TARGET_CC)
+ $(MAKE) -C $(BRIDGE_BUILD_DIR)
$(TARGET_DIR)/sbin/brctl: $(BRIDGE_BUILD_DIR)/brctl/brctl
cp -af $(BRIDGE_BUILD_DIR)/brctl/brctl $(TARGET_DIR)/sbin/
diff --git a/make/iptables.mk b/make/iptables.mk
index 118a316e8..df4341250 100644
--- a/make/iptables.mk
+++ b/make/iptables.mk
@@ -3,7 +3,7 @@
# iptables
#
#############################################################
-IPTABLES_SOURCE_URL=ftp://ftp.netfilter.org/pub/iptables
+IPTABLES_SOURCE_URL=http://www.netfilter.org/files
IPTABLES_SOURCE=iptables-1.2.8.tar.bz2
IPTABLES_BUILD_DIR=$(BUILD_DIR)/iptables-1.2.8