summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
committerEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
commitfc686e3dfe3228bf420e57cee98bc61902d1187b (patch)
tree7d0931acd0179be45ae22a8405069770fca78c65 /make
parent0af92f5e6f57ad00c8e4af266919387daab02227 (diff)
downloadbuildroot-novena-fc686e3dfe3228bf420e57cee98bc61902d1187b.tar.gz
buildroot-novena-fc686e3dfe3228bf420e57cee98bc61902d1187b.zip
Fixup the "older than" (test -ot) tests for older bash
versions when one of the files is missing
Diffstat (limited to 'make')
-rw-r--r--make/findutils.mk3
-rw-r--r--make/grep.mk3
-rw-r--r--make/tar.mk3
3 files changed, 6 insertions, 3 deletions
diff --git a/make/findutils.mk b/make/findutils.mk
index aaac14eaa..111a5ef0d 100644
--- a/make/findutils.mk
+++ b/make/findutils.mk
@@ -51,7 +51,8 @@ $(FINDUTILS_DIR)/$(FINDUTILS_BINARY): $(FINDUTILS_DIR)/.configured
findutils-target_binary: $(FINDUTILS_DIR)/$(FINDUTILS_BINARY)
@if [ -L $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY); fi;
- @if [ $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) -ot $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) ] ; then \
+ @if [ ! -f $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) -o $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) \
+ -ot $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) ] ; then \
set -x; \
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(FINDUTILS_DIR) install; \
$(STRIP) $(TARGET_DIR)/usr/lib/locate/* > /dev/null 2>&1; \
diff --git a/make/grep.mk b/make/grep.mk
index 8fccf5be0..9ccfa4826 100644
--- a/make/grep.mk
+++ b/make/grep.mk
@@ -51,7 +51,8 @@ $(GNUGREP_DIR)/$(GNUGREP_BINARY): $(GNUGREP_DIR)/.configured
grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
@if [ -L $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY); fi;
- @if [ $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) -ot $(GNUGREP_DIR)/$(GNUGREP_BINARY) ] ; then \
+ @if [ ! -f $(GNUGREP_DIR)/$(GNUGREP_BINARY) -o $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) \
+ -ot $(GNUGREP_DIR)/$(GNUGREP_BINARY) ] ; then \
set -x; \
rm -f $(TARGET_DIR)/bin/grep $(TARGET_DIR)/bin/egrep $(TARGET_DIR)/bin/fgrep; \
cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \
diff --git a/make/tar.mk b/make/tar.mk
index c777b58ad..2ea259c09 100644
--- a/make/tar.mk
+++ b/make/tar.mk
@@ -49,7 +49,8 @@ $(GNUTAR_DIR)/$(GNUTAR_BINARY): $(GNUTAR_DIR)/.configured
tar-target_binary: $(GNUTAR_DIR)/$(GNUTAR_BINARY)
@if [ -L $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); fi;
- @if [ $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) -ot $(GNUTAR_DIR)/$(GNUTAR_BINARY) ] ; then \
+ @if [ ! -f $(GNUTAR_DIR)/$(GNUTAR_BINARY) -o $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) \
+ -ot $(GNUTAR_DIR)/$(GNUTAR_BINARY) ] ; then \
set -x; \
rm -f $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); \
cp -a $(GNUTAR_DIR)/$(GNUTAR_BINARY) $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); fi ;