summaryrefslogtreecommitdiffstats
path: root/make/user-mode-linux.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-12-10 23:26:31 +0000
committerEric Andersen <andersen@codepoet.org>2002-12-10 23:26:31 +0000
commit98b6fb27b3fa0960a94e4545b0b7c4498b1dc8e6 (patch)
tree97a40c10cb9b5bc8e36dc27310bcbe2416d1ca38 /make/user-mode-linux.mk
parentbe4cf785bdff65e87ea8abf7b48e09cf78b6ec6d (diff)
downloadbuildroot-novena-98b6fb27b3fa0960a94e4545b0b7c4498b1dc8e6.tar.gz
buildroot-novena-98b6fb27b3fa0960a94e4545b0b7c4498b1dc8e6.zip
Support building regular kernels
Diffstat (limited to 'make/user-mode-linux.mk')
-rw-r--r--make/user-mode-linux.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/make/user-mode-linux.mk b/make/user-mode-linux.mk
index 40c1cc354..09dd66f06 100644
--- a/make/user-mode-linux.mk
+++ b/make/user-mode-linux.mk
@@ -3,6 +3,9 @@
# Linux kernel targets
#
#############################################################
+ifneq ($(filter $(TARGETS),user-mode-linux),)
+
+LINUX_KERNEL=$(BASE_DIR)/UMlinux
UMLINUX_DIR=$(BUILD_DIR)/linux-2.4.19
LINUX_DIR=$(UMLINUX_DIR)
UMLINUX_SOURCE=linux-2.4.19.tar.bz2
@@ -65,3 +68,4 @@ user-mode-linux-dirclean:
#############################################################
linux_headers: $(UMLINUX_DIR)/.configured
+endif