summaryrefslogtreecommitdiffstats
path: root/make/system-linux.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-05 12:07:24 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-05 12:07:24 +0000
commit996495c56925cd76fde8744781cb15aa67a13938 (patch)
tree5f07068ddb0225f5c8b8faad0c283b1b4cd32881 /make/system-linux.mk
parentb3508599767d82eb014a40bed5f939da6e189489 (diff)
downloadbuildroot-novena-996495c56925cd76fde8744781cb15aa67a13938.tar.gz
buildroot-novena-996495c56925cd76fde8744781cb15aa67a13938.zip
Don't mess with the headers files installed by uClibc
Diffstat (limited to 'make/system-linux.mk')
-rw-r--r--make/system-linux.mk14
1 files changed, 1 insertions, 13 deletions
diff --git a/make/system-linux.mk b/make/system-linux.mk
index f12a8e1b5..2f55dd597 100644
--- a/make/system-linux.mk
+++ b/make/system-linux.mk
@@ -47,19 +47,7 @@ $(LINUX_DIR)/.configured:
$(LINUX_KERNEL): $(LINUX_DIR)/.configured
-$(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
- mkdir -p $(STAGING_DIR)/include
- rm -rf $(STAGING_DIR)/include/linux
- cp -dpa $(LINUX_DIR)/include/linux $(STAGING_DIR)/include/
- rm -rf $(STAGING_DIR)/include/asm
- mkdir -p $(STAGING_DIR)/include/asm
- cp -dpa $(LINUX_DIR)/include/asm/* $(STAGING_DIR)/include/asm/
- rm -rf $(STAGING_DIR)/include/scsi
- mkdir -p $(STAGING_DIR)/include/scsi
- cp -dpa $(LINUX_DIR)/include/scsi/* $(STAGING_DIR)/include/scsi
- touch -c $(STAGING_DIR)/include/linux/version.h
-
-system-linux: $(STAGING_DIR)/include/linux/version.h
+system-linux: $(LINUX_DIR)/.configured
system-linux-clean: clean
rm -f $(LINUX_KERNEL)