summaryrefslogtreecommitdiffstats
path: root/make/system-linux.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-04 21:00:20 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-04 21:00:20 +0000
commit82e6f7d125a7a091c83ef88803553eeecd8e7c80 (patch)
treef7e7c0cfdb5574b93707db09a93defc1d0fbca9f /make/system-linux.mk
parentcc16cd656a93e9b05332c5d0b0df518cdf78af23 (diff)
downloadbuildroot-novena-82e6f7d125a7a091c83ef88803553eeecd8e7c80.tar.gz
buildroot-novena-82e6f7d125a7a091c83ef88803553eeecd8e7c80.zip
Fake up an arm-linux source-tree
Diffstat (limited to 'make/system-linux.mk')
-rw-r--r--make/system-linux.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/make/system-linux.mk b/make/system-linux.mk
index 6098cc6bc..f12a8e1b5 100644
--- a/make/system-linux.mk
+++ b/make/system-linux.mk
@@ -31,6 +31,12 @@ $(LINUX_DIR)/.configured:
ln -fs asm-mips asm; \
elif [ "$(ARCH)" = "mipsel" ];then \
ln -fs asm-mips asm; \
+ elif [ "$(ARCH)" = "arm" ];then \
+ ln -fs asm-arm asm; \
+ (cd asm-arm; \
+ if [ ! -L proc ] ; then \
+ ln -fs proc-armv proc; \
+ ln -fs arch-ebsa285 arch; fi); \
elif [ "$(ARCH)" = "cris" ];then \
ln -fs asm-cris asm; \
else ln -fs asm-$(ARCH) asm; \