summaryrefslogtreecommitdiffstats
path: root/make/sed.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2003-11-17 01:31:38 +0000
committerManuel Novoa III <mjn3@codepoet.org>2003-11-17 01:31:38 +0000
commit50e1da8698f484cfcf6793136ea268c3f997d6ea (patch)
tree41b4b9ee3ae7f0ecb179689601ca048b825225b7 /make/sed.mk
parent8162065d968b219e01628d5118683ba41da6c121 (diff)
downloadbuildroot-novena-50e1da8698f484cfcf6793136ea268c3f997d6ea.tar.gz
buildroot-novena-50e1da8698f484cfcf6793136ea268c3f997d6ea.zip
Fix most things when large file support is not configured.
Mostly submitted by Thomas Lundquist <lists@zelow.no>.
Diffstat (limited to 'make/sed.mk')
-rw-r--r--make/sed.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/make/sed.mk b/make/sed.mk
index 58f3221c4..c643f5b17 100644
--- a/make/sed.mk
+++ b/make/sed.mk
@@ -9,6 +9,9 @@ SED_CAT:=zcat
SED_DIR:=$(BUILD_DIR)/sed-3.02
SED_BINARY:=sed/sed
SED_TARGET_BINARY:=bin/sed
+ifeq ($(strip $(BUILD_WITH_LARGEFILE)),true)
+SED_CPPFLAGS=-D_FILE_OFFSET_BITS=64
+endif
$(DL_DIR)/$(SED_SOURCE):
$(WGET) -P $(DL_DIR) $(SED_SITE)/$(SED_SOURCE)
@@ -23,6 +26,7 @@ $(SED_DIR)/.configured: $(SED_DIR)/.unpacked
(cd $(SED_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="$(SED_CFLAGS)" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \