summaryrefslogtreecommitdiffstats
path: root/make/rxvt.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
commit7129da009cc72575a84a30c4587bd99f745c49d4 (patch)
tree5c16654726d0b4c230ed957f88fd1b26be805171 /make/rxvt.mk
parentf7070772fa2fef125169853747ff9aecc4a88962 (diff)
downloadbuildroot-novena-7129da009cc72575a84a30c4587bd99f745c49d4.tar.gz
buildroot-novena-7129da009cc72575a84a30c4587bd99f745c49d4.zip
Merge a bunch of stuff over from the tuxscreen buildroot, with
many updates to make things be more consistant. -Erik
Diffstat (limited to 'make/rxvt.mk')
-rw-r--r--make/rxvt.mk68
1 files changed, 68 insertions, 0 deletions
diff --git a/make/rxvt.mk b/make/rxvt.mk
new file mode 100644
index 000000000..3da4beeb2
--- /dev/null
+++ b/make/rxvt.mk
@@ -0,0 +1,68 @@
+#############################################################
+#
+# rxvt
+#
+#############################################################
+# Copyright (C) 2002 by Tom Walsh <Tom@OpenHardware.net>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+
+RXVT_SOURCE:=rxvt-2.6.4.tar.bz2
+RXVT_PATCH:=$(SOURCE_DIR)/rxvt-2.6.4.patch
+RXVT_SITE:=ftp://ftp.rxvt.org/pub/rxvt/
+RXVT_CAT:=bzcat
+RXVT_DIR:=$(BUILD_DIR)/rxvt-2.6.4
+RXVT_BINARY:=$(RXVT_DIR)/src/rxvt
+
+$(DL_DIR)/$(RXVT_SOURCE):
+ $(WGET) -P $(DL_DIR) $(RXVT_SITE)/$(RXVT_SOURCE)
+
+rxvt-source: $(DL_DIR)/$(RXVT_SOURCE)
+
+$(RXVT_DIR)/.unpacked: $(DL_DIR)/$(RXVT_SOURCE)
+ $(RXVT_CAT) $(DL_DIR)/$(RXVT_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch $(RXVT_DIR)/.unpacked
+
+$(RXVT_DIR)/.configured: $(RXVT_DIR)/.unpacked
+ (cd $(RXVT_DIR); rm -rf config.cache; \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr/X11R6 \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --x-includes=$(TINYX_DIR)/exports/include \
+ --x-libraries=$(TINYX_DIR)/exports/lib \
+ );
+ cat $(RXVT_PATCH) | patch -d $(RXVT_DIR) -p1
+ touch $(RXVT_DIR)/.configured
+
+$(RXVT_BINARY): $(RXVT_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC1) -C $(RXVT_DIR)
+ $(STRIP) -x $(RXVT_BINARY)
+
+$(TARGET_DIR)/usr/X11R6/bin/rxvt: $(RXVT_BINARY)
+ cp -f $(RXVT_BINARY) $(TARGET_DIR)/usr/X11R6/bin
+
+rxvt: tinyx $(TARGET_DIR)/usr/X11R6/bin/rxvt
+
+rxvt-clean:
+ rm -f $(TARGET_DIR)/usr/X11R6/bin/rxvt
+ -$(MAKE) -C $(RXVT_DIR) clean
+
+rxvt-dirclean:
+ rm -rf $(RXVT_DIR)
+