aboutsummaryrefslogtreecommitdiffstats
path: root/make/openssl.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
commit4f889ada561fbdffeefa1a8327d5b8939b021685 (patch)
tree925b247ee7718930f470b2c1843cb15e80a045dd /make/openssl.mk
parent93b677ea4256da1236ae5c4a14b78010e60266d9 (diff)
downloadbuildroot-novena-4f889ada561fbdffeefa1a8327d5b8939b021685.tar.gz
buildroot-novena-4f889ada561fbdffeefa1a8327d5b8939b021685.zip
automatically detect if we have a usable version of sed
installed. If not, we will now build our own version.
Diffstat (limited to 'make/openssl.mk')
-rw-r--r--make/openssl.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/openssl.mk b/make/openssl.mk
index 50d3cf6bb..aa9f9f06e 100644
--- a/make/openssl.mk
+++ b/make/openssl.mk
@@ -17,7 +17,7 @@ $(OPENSSL_DIR)/.unpacked: $(DL_DIR)/$(OPENSSL_SOURCE) $(OPENSSL_PATCH)
gunzip -c $(DL_DIR)/$(OPENSSL_SOURCE) | tar -C $(BUILD_DIR) -xvf -
cat $(OPENSSL_PATCH) | patch -p1 -d $(OPENSSL_DIR)
# sigh... we have to resort to this just to set a gcc flag.
- sed -i -e 's,/CFLAG=,/CFLAG= $(TARGET_SOFT_FLOAT) ,g' \
+ $(SED) 's,/CFLAG=,/CFLAG= $(TARGET_SOFT_FLOAT) ,g' \
$(OPENSSL_DIR)/Configure
touch $(OPENSSL_DIR)/.unpacked