summaryrefslogtreecommitdiffstats
path: root/make/openssl.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-13 20:30:07 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-13 20:30:07 +0000
commit9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f (patch)
tree3e8e5db9d2e2a229c2978e55217f263f0a27ae6d /make/openssl.mk
parent5b89b722a2c6c723a2b59ab3b950d16e6872eca8 (diff)
downloadbuildroot-novena-9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f.tar.gz
buildroot-novena-9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f.zip
Do not blindly strip all symbols from from all libs. libpthread
needs its symbols for pthread debugging to work. Let it be a local decision.
Diffstat (limited to 'make/openssl.mk')
-rw-r--r--make/openssl.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make/openssl.mk b/make/openssl.mk
index 095aa0737..343427819 100644
--- a/make/openssl.mk
+++ b/make/openssl.mk
@@ -56,6 +56,8 @@ $(TARGET_DIR)/usr/lib/libssl.a: $(STAGING_DIR)/lib/libcrypto.so.0.9.7
ln -fs /lib/libssl.so.0.9.7 libssl.so; \
ln -fs /lib/libcrypto.so.0.9.7 libcrypto.so; \
)
+ -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libssl.so.0.9.7
+ -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libcrypto.so.0.9.7
touch -c $(TARGET_DIR)/usr/lib/libssl.a
openssl-headers: $(TARGET_DIR)/usr/lib/libssl.a