aboutsummaryrefslogtreecommitdiffstats
path: root/make/openssh.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
commit1fc3f2f3de0f731c2869a48f951557eed6704218 (patch)
treee5fa011e92f78d0feab200dde260ba21561e76d0 /make/openssh.mk
parent36830baea210bba2490f643a1d147bf9adb2b62b (diff)
downloadbuildroot-novena-1fc3f2f3de0f731c2869a48f951557eed6704218.tar.gz
buildroot-novena-1fc3f2f3de0f731c2869a48f951557eed6704218.zip
Rework things to ensure we are cross compiling. Teach problematic
apps like openssh to cross compile. This eliminates the need for the magic ld-uClibc.so.0 symlink in /lib
Diffstat (limited to 'make/openssh.mk')
-rw-r--r--make/openssh.mk13
1 files changed, 9 insertions, 4 deletions
diff --git a/make/openssh.mk b/make/openssh.mk
index 21a04c2a7..af7b12994 100644
--- a/make/openssh.mk
+++ b/make/openssh.mk
@@ -7,24 +7,29 @@
OPENSSH_SITE:=ftp://ftp.tux.org/bsd/openbsd/OpenSSH/portable/
OPENSSH_DIR:=$(BUILD_DIR)/openssh-3.5p1
OPENSSH_SOURCE:=openssh-3.5p1.tar.gz
+OPENSSH_PATCH:=$(SOURCE_DIR)/openssh.patch
$(DL_DIR)/$(OPENSSH_SOURCE):
$(WGET) -P $(DL_DIR) $(OPENSSH_SITE)/$(OPENSSH_SOURCE)
-$(OPENSSH_DIR)/.unpacked: $(DL_DIR)/$(OPENSSH_SOURCE)
+$(OPENSSH_DIR)/.unpacked: $(DL_DIR)/$(OPENSSH_SOURCE) $(OPENSSH_PATCH)
zcat $(DL_DIR)/$(OPENSSH_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ cat $(OPENSSH_PATCH) | patch -p1 -d $(OPENSSH_DIR)
touch $(OPENSSH_DIR)/.unpacked
$(OPENSSH_DIR)/.configured: $(OPENSSH_DIR)/.unpacked
- (cd $(OPENSSH_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ (cd $(OPENSSH_DIR); rm -rf config.cache; autoconf; \
+ $(TARGET_CONFIGURE_OPTS) \
+ LD=$(TARGET_CROSS)gcc \
./configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
+ --libexecdir=/usr/sbin \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \