summaryrefslogtreecommitdiffstats
path: root/make/ncurses.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-13 20:30:07 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-13 20:30:07 +0000
commit9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f (patch)
tree3e8e5db9d2e2a229c2978e55217f263f0a27ae6d /make/ncurses.mk
parent5b89b722a2c6c723a2b59ab3b950d16e6872eca8 (diff)
downloadbuildroot-novena-9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f.tar.gz
buildroot-novena-9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f.zip
Do not blindly strip all symbols from from all libs. libpthread
needs its symbols for pthread debugging to work. Let it be a local decision.
Diffstat (limited to 'make/ncurses.mk')
-rw-r--r--make/ncurses.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make/ncurses.mk b/make/ncurses.mk
index 7cc794738..e499de4a8 100644
--- a/make/ncurses.mk
+++ b/make/ncurses.mk
@@ -5,7 +5,7 @@
#
#############################################################
# Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.23 2003/03/04 19:16:18 andersen Exp $
+# $Id: ncurses.mk,v 1.24 2003/03/13 20:30:07 andersen Exp $
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU Library General Public License as
@@ -109,6 +109,7 @@ $(TARGET_DIR)/usr/lib/libncurses.a: $(STAGING_DIR)/lib/libncurses.a
(cd $(TARGET_DIR)/usr/include; ln -fs ncurses.h curses.h)
rm -f $(TARGET_DIR)/lib/libncurses.so
(cd $(TARGET_DIR)/usr/lib; ln -fs /lib/libncurses.so.5.2 libncurses.so)
+ -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libncurses.so.5.2
touch -c $(TARGET_DIR)/usr/lib/libncurses.a
ncurses-headers: $(TARGET_DIR)/usr/lib/libncurses.a