summaryrefslogtreecommitdiffstats
path: root/make/ncurses.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-08 02:29:25 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-08 02:29:25 +0000
commit0cea77f96142926f775600dc6a382d3565c56481 (patch)
treef1e34ccc1a515dc0ec5181073a764911af8f900e /make/ncurses.mk
parent446eb7ed8ba0d787c90108a041eeea0906e7fd7a (diff)
downloadbuildroot-novena-0cea77f96142926f775600dc6a382d3565c56481.tar.gz
buildroot-novena-0cea77f96142926f775600dc6a382d3565c56481.zip
Add an optional ncurses-headers target to install target header files
-Erik
Diffstat (limited to 'make/ncurses.mk')
-rw-r--r--make/ncurses.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/make/ncurses.mk b/make/ncurses.mk
index b021b30e0..420cd3fde 100644
--- a/make/ncurses.mk
+++ b/make/ncurses.mk
@@ -5,7 +5,7 @@
#
#############################################################
# Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.10 2003/01/02 08:43:57 andersen Exp $
+# $Id: ncurses.mk,v 1.11 2003/01/08 02:29:25 andersen Exp $
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU Library General Public License as
@@ -72,6 +72,19 @@ $(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.so
tar -C $(TARGET_DIR)/usr/share/ -xf - ; \
done
+$(TARGET_DIR)/include/curses.h: $(TARGET_DIR)/lib/libncurses.so
+ cp -dpf $(NCURSES_DIR)/include/curses.h $(TARGET_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/eti.h $(TARGET_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/form.h $(TARGET_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/menu.h $(TARGET_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/panel.h $(TARGET_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/term.h $(TARGET_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/termcap.h $(TARGET_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/unctrl.h $(TARGET_DIR)/include/
+ (cd $(TARGET_DIR)/include; ln -fs curses.h ncurses.h)
+
+ncurses-headers: $(TARGET_DIR)/include/curses.h
+
ncurses-clean:
rm -f $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/libncurses.so*
rm -f $(STAGING_DIR)/usr/share/tabset $(TARGET_DIR)/usr/share/tabset