summaryrefslogtreecommitdiffstats
path: root/make/make.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-02-12 08:10:40 +0000
committerEric Andersen <andersen@codepoet.org>2003-02-12 08:10:40 +0000
commitd322f37644811964ee7da64c4d3fcffd8898869f (patch)
treef7e2ba6c81659bb3db7257d894df9bffe7507db0 /make/make.mk
parente03eb9438ec2a2a8036f025df8cd112c1b686c63 (diff)
downloadbuildroot-novena-d322f37644811964ee7da64c4d3fcffd8898869f.tar.gz
buildroot-novena-d322f37644811964ee7da64c4d3fcffd8898869f.zip
Lots and lots of changes
Diffstat (limited to 'make/make.mk')
-rw-r--r--make/make.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/make/make.mk b/make/make.mk
index b0a82a83e..08240d937 100644
--- a/make/make.mk
+++ b/make/make.mk
@@ -21,7 +21,7 @@ $(GNUMAKE_DIR)/.unpacked: $(DL_DIR)/$(GNUMAKE_SOURCE)
$(GNUMAKE_DIR)/.configured: $(GNUMAKE_DIR)/.unpacked
(cd $(GNUMAKE_DIR); rm -rf config.cache; \
- PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC) \
+ PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
./configure \
--target=$(GNU_TARGET_NAME) \
--prefix=/usr \
@@ -39,17 +39,17 @@ $(GNUMAKE_DIR)/.configured: $(GNUMAKE_DIR)/.unpacked
touch $(GNUMAKE_DIR)/.configured
$(GNUMAKE_DIR)/$(GNUMAKE_BINARY): $(GNUMAKE_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(GNUMAKE_DIR)
+ $(MAKE) -C $(GNUMAKE_DIR)
$(TARGET_DIR)/$(GNUMAKE_TARGET_BINARY): $(GNUMAKE_DIR)/$(GNUMAKE_BINARY)
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(GNUMAKE_DIR) install
+ $(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUMAKE_DIR) install
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
make: uclibc $(TARGET_DIR)/$(GNUMAKE_TARGET_BINARY)
make-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(GNUMAKE_DIR) uninstall
+ $(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUMAKE_DIR) uninstall
-$(MAKE) -C $(GNUMAKE_DIR) clean
make-dirclean: