aboutsummaryrefslogtreecommitdiffstats
path: root/make/libtool.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-02-05 10:43:44 +0000
committerEric Andersen <andersen@codepoet.org>2003-02-05 10:43:44 +0000
commit95ff38838b2854efd1ced496d11c73f17f174c41 (patch)
tree31b5bb8d42d025648459fa336bb37f08ca078f5f /make/libtool.mk
parent9cee91877fce77896694b91d1279391a77b6de0c (diff)
downloadbuildroot-novena-95ff38838b2854efd1ced496d11c73f17f174c41.tar.gz
buildroot-novena-95ff38838b2854efd1ced496d11c73f17f174c41.zip
teach libtool to use the correct system compiler
Diffstat (limited to 'make/libtool.mk')
-rw-r--r--make/libtool.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make/libtool.mk b/make/libtool.mk
index aa754a923..53038cbae 100644
--- a/make/libtool.mk
+++ b/make/libtool.mk
@@ -58,6 +58,8 @@ $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
mandir=$(TARGET_DIR)/usr/man \
includedir=$(TARGET_DIR)/usr/include \
-C $(LIBTOOL_DIR) install;
+ perl -pi -e "s,^CC.*,CC=\"/usr/bin/gcc\"," $(TARGET_DIR)/usr/bin/libtool
+ perl -pi -e "s,^LD.*,CC=\"/usr/bin/ld\"," $(TARGET_DIR)/usr/bin/libtool
rm -rf $(TARGET_DIR)/share/locale
libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)