summaryrefslogtreecommitdiffstats
path: root/make/kernel-headers.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
commit3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee (patch)
tree935da51d77ee95870a094a5ae927b52c2c56cd48 /make/kernel-headers.mk
parent7e7644913a5530adab36489fd8c499f34de7eac2 (diff)
downloadbuildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.tar.gz
buildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.zip
Patch by michael tesch <tesch1@gmail.com> ...
The real problem, only caused when you have a *.patch file in the main build directory, is that the Makefiles don't escape the globbing operator they're passing to patch-kernel.sh. Attached is a patch to fix that.
Diffstat (limited to 'make/kernel-headers.mk')
-rw-r--r--make/kernel-headers.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/kernel-headers.mk b/make/kernel-headers.mk
index 0eb2035fc..07c2bd5d9 100644
--- a/make/kernel-headers.mk
+++ b/make/kernel-headers.mk
@@ -56,7 +56,7 @@ endif
touch $(LINUX_DIR)/.unpacked
$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
- $(SOURCE_DIR)/patch-kernel.sh $(LINUX_DIR) $(SOURCE_DIR) linux-libc-headers-$(LINUX_VERSION)-*.patch
+ $(SOURCE_DIR)/patch-kernel.sh $(LINUX_DIR) $(SOURCE_DIR) linux-libc-headers-$(LINUX_VERSION)-\*.patch
touch $(LINUX_DIR)/.patched
$(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched