aboutsummaryrefslogtreecommitdiffstats
path: root/make/iptables.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-07-27 04:00:50 +0000
committerEric Andersen <andersen@codepoet.org>2003-07-27 04:00:50 +0000
commit669f7d88b33ebe5ef09993fbee3c466139a05d4c (patch)
tree09d125cd05c52445deaf415449b5d508a1913123 /make/iptables.mk
parent9fe57b89a9f2da55bd0bffd238cb15bc2693016e (diff)
downloadbuildroot-novena-669f7d88b33ebe5ef09993fbee3c466139a05d4c.tar.gz
buildroot-novena-669f7d88b33ebe5ef09993fbee3c466139a05d4c.zip
Patch from Michael Shuler. Update to version 1.2.8 and remember to
copy all the required shared libs -- without them iptables dosen't do very much.
Diffstat (limited to 'make/iptables.mk')
-rw-r--r--make/iptables.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/make/iptables.mk b/make/iptables.mk
index d7f15ae8d..921db7053 100644
--- a/make/iptables.mk
+++ b/make/iptables.mk
@@ -4,8 +4,8 @@
#
#############################################################
IPTABLES_SOURCE_URL=ftp://ftp.netfilter.org/pub/iptables
-IPTABLES_SOURCE=iptables-1.2.7a.tar.bz2
-IPTABLES_BUILD_DIR=$(BUILD_DIR)/iptables-1.2.7a
+IPTABLES_SOURCE=iptables-1.2.8.tar.bz2
+IPTABLES_BUILD_DIR=$(BUILD_DIR)/iptables-1.2.8
$(DL_DIR)/$(IPTABLES_SOURCE):
$(WGET) -P $(DL_DIR) $(IPTABLES_SOURCE_URL)/$(IPTABLES_SOURCE)
@@ -28,6 +28,8 @@ $(TARGET_DIR)/sbin/iptables: $(IPTABLES_BUILD_DIR)/iptables
cp -af $(IPTABLES_BUILD_DIR)/iptables $(TARGET_DIR)/sbin/
cp -af $(IPTABLES_BUILD_DIR)/iptables-save $(TARGET_DIR)/sbin/
cp -af $(IPTABLES_BUILD_DIR)/iptables-restore $(TARGET_DIR)/sbin/
+ -mkdir $(TARGET_DIR)/usr/local/lib/iptables
+ cp -af $(IPTABLES_BUILD_DIR)/extensions/*.so $(TARGET_DIR)/usr/local/lib/iptables/
iptables: $(TARGET_DIR)/sbin/iptables