aboutsummaryrefslogtreecommitdiffstats
path: root/make/iptables.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
commit3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee (patch)
tree935da51d77ee95870a094a5ae927b52c2c56cd48 /make/iptables.mk
parent7e7644913a5530adab36489fd8c499f34de7eac2 (diff)
downloadbuildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.tar.gz
buildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.zip
Patch by michael tesch <tesch1@gmail.com> ...
The real problem, only caused when you have a *.patch file in the main build directory, is that the Makefiles don't escape the globbing operator they're passing to patch-kernel.sh. Attached is a patch to fix that.
Diffstat (limited to 'make/iptables.mk')
-rw-r--r--make/iptables.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/iptables.mk b/make/iptables.mk
index 886e54213..937348a53 100644
--- a/make/iptables.mk
+++ b/make/iptables.mk
@@ -16,7 +16,7 @@ $(IPTABLES_BUILD_DIR)/.unpacked: $(DL_DIR)/$(IPTABLES_SOURCE)
$(IPTABLES_BUILD_DIR)/.configured: $(IPTABLES_BUILD_DIR)/.unpacked
# Allow patches. Needed for openwrt for instance.
- $(SOURCE_DIR)/patch-kernel.sh $(IPTABLES_BUILD_DIR) $(SOURCE_DIR) iptables-*.patch
+ $(SOURCE_DIR)/patch-kernel.sh $(IPTABLES_BUILD_DIR) $(SOURCE_DIR) iptables-\*.patch
#
$(SED) "s;\[ -f /usr/include/netinet/ip6.h \];grep -q '__UCLIBC_HAS_IPV6__ 1' \
$(BUILD_DIR)/uClibc/include/bits/uClibc_config.h;" $(IPTABLES_BUILD_DIR)/Makefile