summaryrefslogtreecommitdiffstats
path: root/make/iproute2.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
commit620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d (patch)
treeaa08afb7d58fabed8f365bf373751992b792680c /make/iproute2.mk
parent192bace39e7c0fe5c4ccf9add25b67cb37f8abdc (diff)
downloadbuildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.tar.gz
buildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.zip
By popular demand, use 'sed' rather than 'perl' for doing
search and replace stuff. Hopefully we do not have any perl specific regexs that will be broken by this change, but it seems to be working thus far anyways,
Diffstat (limited to 'make/iproute2.mk')
-rw-r--r--make/iproute2.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/make/iproute2.mk b/make/iproute2.mk
index 0863277d8..ba49864b7 100644
--- a/make/iproute2.mk
+++ b/make/iproute2.mk
@@ -29,14 +29,14 @@ $(IPROUTE2_DIR)/.unpacked: $(DL_DIR)/$(IPROUTE2_SOURCE) #$(DL_DIR)/$(IPROUTE2_PA
touch $(IPROUTE2_DIR)/.unpacked
$(IPROUTE2_DIR)/.configured: $(IPROUTE2_DIR)/.unpacked
- perl -pi -e "s,-I/usr/include/db3,," $(IPROUTE2_DIR)/Makefile
- perl -pi -e "s,^KERNEL_INCLUDE.*,KERNEL_INCLUDE=$(LINUX_DIR)/include," \
+ sed -ie "s,-I/usr/include/db3,," $(IPROUTE2_DIR)/Makefile
+ sed -ie "s,^KERNEL_INCLUDE.*,KERNEL_INCLUDE=$(LINUX_DIR)/include," \
$(IPROUTE2_DIR)/Makefile
- perl -pi -e "s,^LIBC_INCLUDE.*,LIBC_INCLUDE=$(STAGING_DIR)/include," \
+ sed -ie "s,^LIBC_INCLUDE.*,LIBC_INCLUDE=$(STAGING_DIR)/include," \
$(IPROUTE2_DIR)/Makefile
# For now disable compiling of the misc directory because it seems to fail
rm -rf $(IPROUTE2_DIR)/misc
- perl -pi -e "s, misc,," $(IPROUTE2_DIR)/Makefile
+ sed -ie "s, misc,," $(IPROUTE2_DIR)/Makefile
touch $(IPROUTE2_DIR)/.configured
$(IPROUTE2_DIR)/tc/tc: $(IPROUTE2_DIR)/.configured