aboutsummaryrefslogtreecommitdiffstats
path: root/make/gdb.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
commit3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee (patch)
tree935da51d77ee95870a094a5ae927b52c2c56cd48 /make/gdb.mk
parent7e7644913a5530adab36489fd8c499f34de7eac2 (diff)
downloadbuildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.tar.gz
buildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.zip
Patch by michael tesch <tesch1@gmail.com> ...
The real problem, only caused when you have a *.patch file in the main build directory, is that the Makefiles don't escape the globbing operator they're passing to patch-kernel.sh. Attached is a patch to fix that.
Diffstat (limited to 'make/gdb.mk')
-rw-r--r--make/gdb.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/gdb.mk b/make/gdb.mk
index 4030ede7f..e1f590f6c 100644
--- a/make/gdb.mk
+++ b/make/gdb.mk
@@ -22,7 +22,7 @@ $(DL_DIR)/$(GDB_SOURCE):
$(GDB_DIR)/.unpacked: $(DL_DIR)/$(GDB_SOURCE)
$(GDB_CAT) $(DL_DIR)/$(GDB_SOURCE) | tar -C $(TOOL_BUILD_DIR) -xvf -
- $(SOURCE_DIR)/patch-kernel.sh $(GDB_DIR) $(SOURCE_DIR)/gdb/$(GDB_VERSION) *.patch
+ $(SOURCE_DIR)/patch-kernel.sh $(GDB_DIR) $(SOURCE_DIR)/gdb/$(GDB_VERSION) \*.patch
# Copy a config.sub from gcc. This is only necessary until
# gdb's config.sub supports <arch>-linux-uclibc tuples.
# Should probably integrate this into the patch.