aboutsummaryrefslogtreecommitdiffstats
path: root/make/gcc-uclibc-2.95.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-01-14 19:05:27 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-01-14 19:05:27 +0000
commit0f92b0198868ac15fa6d3ece5acabe2d8d427072 (patch)
tree985af5da30acf4ae1b3d6528921e16d2483fbb2f /make/gcc-uclibc-2.95.mk
parent7138a960444736d63d386dbd8502028cad5f9633 (diff)
downloadbuildroot-novena-0f92b0198868ac15fa6d3ece5acabe2d8d427072.tar.gz
buildroot-novena-0f92b0198868ac15fa6d3ece5acabe2d8d427072.zip
Oops... forgot --with-headers when building the cross compilers. So the
version of limits.h under gcc-lib was incorrect.
Diffstat (limited to 'make/gcc-uclibc-2.95.mk')
-rw-r--r--make/gcc-uclibc-2.95.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/make/gcc-uclibc-2.95.mk b/make/gcc-uclibc-2.95.mk
index 1feb98bf3..c9f1b92da 100644
--- a/make/gcc-uclibc-2.95.mk
+++ b/make/gcc-uclibc-2.95.mk
@@ -75,6 +75,8 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# # the step or libgcc will not build...
$(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
mkdir -p $(GCC_BUILD_DIR1)
+ -mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include
+ -(cd $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) ; ln -sf include sys-include)
(cd $(GCC_BUILD_DIR1); PATH=$(TARGET_PATH) \
$(GCC_DIR)/configure \
--prefix=$(STAGING_DIR) \
@@ -84,6 +86,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
--enable-languages=c \
--disable-shared \
--includedir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include \
+ --with-headers \
--disable-__cxa_atexit \
--enable-target-optspace \
--with-gnu-ld \
@@ -164,6 +167,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(STAGING_DIR)/$(REAL_GNU_TAR
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--with-gxx-include-dir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include/c++ \
+ --with-headers \
--disable-__cxa_atexit \
--enable-target-optspace \
--with-gnu-ld \