aboutsummaryrefslogtreecommitdiffstats
path: root/make/gcc-uclibc-2.95.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-02-18 08:28:28 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-02-18 08:28:28 +0000
commit04eadcdcc2d09ace98041ba1fcb9d207a4300bc3 (patch)
treec4b5bad2b34071ec913f994ac605f4461b48eece /make/gcc-uclibc-2.95.mk
parent08b2ca64df7444a1eceec061bb2de948d4964c21 (diff)
downloadbuildroot-novena-04eadcdcc2d09ace98041ba1fcb9d207a4300bc3.tar.gz
buildroot-novena-04eadcdcc2d09ace98041ba1fcb9d207a4300bc3.zip
Update binutils from 2.14.90.0.6 to 2.14.90.0.8.
Update from gcc 3.3.2 to 3.3.3. Test builds done for i386 and mipsel (3.3.3) and i386 (2.95). Soft float support not yet tested with 3.3.3.
Diffstat (limited to 'make/gcc-uclibc-2.95.mk')
-rw-r--r--make/gcc-uclibc-2.95.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/make/gcc-uclibc-2.95.mk b/make/gcc-uclibc-2.95.mk
index a86809613..65a2e4e60 100644
--- a/make/gcc-uclibc-2.95.mk
+++ b/make/gcc-uclibc-2.95.mk
@@ -1,6 +1,7 @@
# Makefile for to build a gcc/uClibc toolchain
#
# Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
+# Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -75,7 +76,8 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
$(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
mkdir -p $(GCC_BUILD_DIR1)
-mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include
- -(cd $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) ; ln -sf include sys-include)
+ # Important! Required for limits.h to be fixed.
+ ln -sf include $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
(cd $(GCC_BUILD_DIR1); PATH=$(TARGET_PATH) \
$(GCC_DIR)/configure \
--prefix=$(STAGING_DIR) \
@@ -85,7 +87,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
--enable-languages=c \
--disable-shared \
--includedir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include \
- --with-headers \
+ --with-headers=$(TOOL_BUILD_DIR)/uClibc_dev/usr/include \
--disable-__cxa_atexit \
--enable-target-optspace \
--with-gnu-ld \
@@ -166,7 +168,6 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(STAGING_DIR)/$(REAL_GNU_TAR
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--with-gxx-include-dir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include/c++ \
- --with-headers \
--disable-__cxa_atexit \
--enable-target-optspace \
--with-gnu-ld \