aboutsummaryrefslogtreecommitdiffstats
path: root/make/flex.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
commit1fc3f2f3de0f731c2869a48f951557eed6704218 (patch)
treee5fa011e92f78d0feab200dde260ba21561e76d0 /make/flex.mk
parent36830baea210bba2490f643a1d147bf9adb2b62b (diff)
downloadbuildroot-novena-1fc3f2f3de0f731c2869a48f951557eed6704218.tar.gz
buildroot-novena-1fc3f2f3de0f731c2869a48f951557eed6704218.zip
Rework things to ensure we are cross compiling. Teach problematic
apps like openssh to cross compile. This eliminates the need for the magic ld-uClibc.so.0 symlink in /lib
Diffstat (limited to 'make/flex.mk')
-rw-r--r--make/flex.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/make/flex.mk b/make/flex.mk
index d37a9f7fe..aa2f8573d 100644
--- a/make/flex.mk
+++ b/make/flex.mk
@@ -26,9 +26,11 @@ $(FLEX_DIR)/.unpacked: $(DL_DIR)/$(FLEX_SOURCE) $(DL_DIR)/$(FLEX_PATCH)
$(FLEX_DIR)/.configured: $(FLEX_DIR)/.unpacked
(cd $(FLEX_DIR); autoconf; rm -rf config.cache; \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ $(TARGET_CONFIGURE_OPTS) \
./configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \