summaryrefslogtreecommitdiffstats
path: root/make/ext2root.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-17 04:32:44 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-17 04:32:44 +0000
commit2fc6cd6a24e95fef9a3d072f6d07f236c739f598 (patch)
treef03d2527a3a0bbe851c9e4d6871649c5070be2a6 /make/ext2root.mk
parent27bc59d4885057c6a167b386ba6140b7a95e5fd7 (diff)
downloadbuildroot-novena-2fc6cd6a24e95fef9a3d072f6d07f236c739f598.tar.gz
buildroot-novena-2fc6cd6a24e95fef9a3d072f6d07f236c739f598.zip
Cleanup the mess in the ext2 target
Diffstat (limited to 'make/ext2root.mk')
-rw-r--r--make/ext2root.mk15
1 files changed, 2 insertions, 13 deletions
diff --git a/make/ext2root.mk b/make/ext2root.mk
index 564c45b8f..1e4b9f133 100644
--- a/make/ext2root.mk
+++ b/make/ext2root.mk
@@ -28,21 +28,10 @@ genext2fs: $(GENEXT2_DIR)/genext2fs
#
# Build the ext2 root filesystem image
#
-# Known problems :
-# - genext2fs: couldn't allocate a block (no free space)
-#
-# Since genext2fs allocates only one group of blocks, the FS
-# size is limited to a maximum of 8 Mb.
-#
#############################################################
-# how much KB we want to add to the calculated size for the root directory,
-# to have additional space
-GENEXT2_ADDTOROOTSIZE := 512
-# maximal rootfilesystem size that can be handled
-# by genext2fs
-GENEXT2_MAXROOTSIZE := 8192
-
+# How much KB we want to add to the calculated size for slack space
+GENEXT2_ADDTOROOTSIZE=4096
GENEXT2_REALSIZE=$(subst total,, $(shell du $(TARGET_DIR) -s -c -k | grep total ))
GENEXT2_SIZE=$(shell expr $(GENEXT2_REALSIZE) + $(GENEXT2_ADDTOROOTSIZE))
# We currently add about 400 device nodes, so add that into the total