summaryrefslogtreecommitdiffstats
path: root/make/customize.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-18 07:18:26 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-18 07:18:26 +0000
commit79c815622a1698fc874d4dfa050491f7f20444b5 (patch)
tree6e3162ab49173435fb91c6a3e1465655674bc4cc /make/customize.mk
parent5dc91b65204888e9ddbfdd7120f46c8a96f93f98 (diff)
downloadbuildroot-novena-79c815622a1698fc874d4dfa050491f7f20444b5.tar.gz
buildroot-novena-79c815622a1698fc874d4dfa050491f7f20444b5.zip
Change 'sed -ie' to 'sed -i -e' to avoid littering the build
with lots of unwanted backup files with the letter "e" appended. -Erik
Diffstat (limited to 'make/customize.mk')
-rw-r--r--make/customize.mk15
1 files changed, 13 insertions, 2 deletions
diff --git a/make/customize.mk b/make/customize.mk
index 2cfed1834..817fe878a 100644
--- a/make/customize.mk
+++ b/make/customize.mk
@@ -3,8 +3,19 @@
# Any custom stuff you feel like doing....
#
#############################################################
-CUST_DIR:=$(SOURCE_DIR)/customize
+CUST_DIR:=$(BASE_DIR)/Erik-Router
ROOT_DIR:=$(BUILD_DIR)/root
customize:
- cp -af $(CUST_DIR)/* $(ROOT_DIR)/
+ cp $(CUST_DIR)/ext2root.mk $(BASE_DIR)/make/
+ cp $(CUST_DIR)/interfaces $(ROOT_DIR)/etc/network/
+ cp $(CUST_DIR)/eth* $(ROOT_DIR)/etc/network/
+ chmod a+x $(ROOT_DIR)/etc/network/eth*
+ cp $(CUST_DIR)/inittab $(ROOT_DIR)/etc/
+ cp $(CUST_DIR)/vtun* $(ROOT_DIR)/etc/
+ cp $(CUST_DIR)/udhcp* $(ROOT_DIR)/etc/
+ cp $(CUST_DIR)/shadow $(ROOT_DIR)/etc/
+ cp $(CUST_DIR)/wireless $(ROOT_DIR)/etc/pcmcia/
+ cp $(CUST_DIR)/resolv.conf $(ROOT_DIR)/etc/
+ cp $(CUST_DIR)/ssh_host* $(ROOT_DIR)/etc/
+ chmod go-r $(ROOT_DIR)/etc/ssh_host*