aboutsummaryrefslogtreecommitdiffstats
path: root/make/coreutils.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
commit620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d (patch)
treeaa08afb7d58fabed8f365bf373751992b792680c /make/coreutils.mk
parent192bace39e7c0fe5c4ccf9add25b67cb37f8abdc (diff)
downloadbuildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.tar.gz
buildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.zip
By popular demand, use 'sed' rather than 'perl' for doing
search and replace stuff. Hopefully we do not have any perl specific regexs that will be broken by this change, but it seems to be working thus far anyways,
Diffstat (limited to 'make/coreutils.mk')
-rw-r--r--make/coreutils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/make/coreutils.mk b/make/coreutils.mk
index 5c4e28a28..1a4f1c298 100644
--- a/make/coreutils.mk
+++ b/make/coreutils.mk
@@ -45,10 +45,10 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
);
#Fix up the max number of open files per process, which apparently
# is not set when cross compiling
- perl -i -p -e 's,.*UTILS_OPEN_MAX.*,#define UTILS_OPEN_MAX 1019,g' \
+ sed -ie 's,.*UTILS_OPEN_MAX.*,#define UTILS_OPEN_MAX 1019,g' \
$(COREUTILS_DIR)/config.h
# This is undefined when crosscompiling...
- perl -i -p -e 's,.*HAVE_PROC_UPTIME.*,#define HAVE_PROC_UPTIME 1,g' \
+ sed -ie 's,.*HAVE_PROC_UPTIME.*,#define HAVE_PROC_UPTIME 1,g' \
$(COREUTILS_DIR)/config.h
touch $(COREUTILS_DIR)/.configured