aboutsummaryrefslogtreecommitdiffstats
path: root/make/coreutils.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
commit4f889ada561fbdffeefa1a8327d5b8939b021685 (patch)
tree925b247ee7718930f470b2c1843cb15e80a045dd /make/coreutils.mk
parent93b677ea4256da1236ae5c4a14b78010e60266d9 (diff)
downloadbuildroot-novena-4f889ada561fbdffeefa1a8327d5b8939b021685.tar.gz
buildroot-novena-4f889ada561fbdffeefa1a8327d5b8939b021685.zip
automatically detect if we have a usable version of sed
installed. If not, we will now build our own version.
Diffstat (limited to 'make/coreutils.mk')
-rw-r--r--make/coreutils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/make/coreutils.mk b/make/coreutils.mk
index 33cd847e4..825c0f354 100644
--- a/make/coreutils.mk
+++ b/make/coreutils.mk
@@ -46,10 +46,10 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
);
#Fix up the max number of open files per process, which apparently
# is not set when cross compiling
- sed -i -e 's,.*UTILS_OPEN_MAX.*,#define UTILS_OPEN_MAX 1019,g' \
+ $(SED) 's,.*UTILS_OPEN_MAX.*,#define UTILS_OPEN_MAX 1019,g' \
$(COREUTILS_DIR)/config.h
# This is undefined when crosscompiling...
- sed -i -e 's,.*HAVE_PROC_UPTIME.*,#define HAVE_PROC_UPTIME 1,g' \
+ $(SED) 's,.*HAVE_PROC_UPTIME.*,#define HAVE_PROC_UPTIME 1,g' \
$(COREUTILS_DIR)/config.h
touch $(COREUTILS_DIR)/.configured