summaryrefslogtreecommitdiffstats
path: root/make/binutils.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
commit0fee9e90c2ea3accfaa521a303c6568ebf7baccc (patch)
tree2d18515f482954fb771dc19671c9056511f71127 /make/binutils.mk
parente150f3921b20b1b35a42d0b34067773814675d8a (diff)
downloadbuildroot-novena-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.tar.gz
buildroot-novena-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.zip
Thomas Cameron writes:
this patch fixes the source file downloads when executing a "make source", and a few cut-and-paste (tm) errors in the *.mk files. Again, this is a patch against the current CVS sources, and includes my previous patch.
Diffstat (limited to 'make/binutils.mk')
-rw-r--r--make/binutils.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/make/binutils.mk b/make/binutils.mk
index fa754085e..85c9eea32 100644
--- a/make/binutils.mk
+++ b/make/binutils.mk
@@ -9,6 +9,7 @@ BINUTILS_DIR:=$(TOOL_BUILD_DIR)/binutils-2.14.90.0.6
BINUTILS_CAT:=bzcat
BINUTILS_DIR1:=$(TOOL_BUILD_DIR)/binutils-build
+
$(DL_DIR)/$(BINUTILS_SOURCE):
$(WGET) -P $(DL_DIR) $(BINUTILS_SITE)/$(BINUTILS_SOURCE)
@@ -98,6 +99,8 @@ $(STAGING_DIR)/lib/libg.a:
binutils: $(STAGING_DIR)/$(GNU_TARGET_NAME)/bin/ld $(STAGING_DIR)/lib/libg.a
+binutils-source: $(DL_DIR)/$(BINUTILS_SOURCE)
+
binutils-clean:
rm -f $(STAGING_DIR)/bin/$(GNU_TARGET_NAME)*
-$(MAKE) -C $(BINUTILS_DIR1) clean
@@ -198,7 +201,3 @@ binutils_target-clean:
binutils_target-dirclean:
rm -rf $(BINUTILS_DIR2)
-
-
-
-