aboutsummaryrefslogtreecommitdiffstats
path: root/make/binutils-uclibc.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-02-06 10:16:11 +0000
committerEric Andersen <andersen@codepoet.org>2004-02-06 10:16:11 +0000
commit05c5b52eefa498fdd43ccf04965159c1bd176ec9 (patch)
tree841fe5a3dca2b8ae9d14dd4746c83d7ee68d7643 /make/binutils-uclibc.mk
parent1e1355a2c1ef147105feb64d2885d733fe67a44f (diff)
downloadbuildroot-novena-05c5b52eefa498fdd43ccf04965159c1bd176ec9.tar.gz
buildroot-novena-05c5b52eefa498fdd43ccf04965159c1bd176ec9.zip
Add a check to ensure the proper utilities are installed before
trying to build binutils, lest folks get cryptic error msgs later. -Erik
Diffstat (limited to 'make/binutils-uclibc.mk')
-rw-r--r--make/binutils-uclibc.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/make/binutils-uclibc.mk b/make/binutils-uclibc.mk
index 326c42155..38318b887 100644
--- a/make/binutils-uclibc.mk
+++ b/make/binutils-uclibc.mk
@@ -45,7 +45,21 @@ $(BINUTILS_DIR1)/binutils/objdump: $(BINUTILS_DIR1)/.configured
$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld: $(BINUTILS_DIR1)/binutils/objdump
$(MAKE) $(JLEVEL) -C $(BINUTILS_DIR1) install
-binutils: $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld
+binutils-dependancies:
+ @if [ ! -x /usr/bin/bison ] ; then \
+ echo -e "\n\nYou must install 'bison' on your build machine\n"; \
+ exit 1; \
+ fi;
+ @if [ ! -x /usr/bin/flex ] ; then \
+ echo -e "\n\nYou must install 'flex' on your build machine\n"; \
+ exit 1; \
+ fi;
+ @if [ ! -x /usr/bin/msgfmt ] ; then \
+ echo -e "\n\nYou must install 'gettext' on your build machine\n"; \
+ exit 1; \
+ fi;
+
+binutils: binutils-dependancies $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld
binutils-source: $(DL_DIR)/$(BINUTILS_SOURCE)