summaryrefslogtreecommitdiffstats
path: root/linux/linux-ext-ocf-linux.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-04-27 10:09:44 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-05 22:59:14 +0200
commit20e1e84272701413574633dafe207b40c2a5d6dd (patch)
tree36e3a283a7aa19efc68c7615945aa2319cfd2bed /linux/linux-ext-ocf-linux.mk
parent80ebf12906afc3a1e5f4e5682d4c5dc0779a556a (diff)
downloadbuildroot-novena-20e1e84272701413574633dafe207b40c2a5d6dd.tar.gz
buildroot-novena-20e1e84272701413574633dafe207b40c2a5d6dd.zip
ocf-linux: remove extension and build out of tree
Remove the OCF linux kernel extension instead opting to build ocf-linux modules out of tree. This is easier for users since no kernel config tweaking is required. On the downside the OCF drivers can't be used, but then all of the kernel crypto drivers are available to users via cryptosoft which is preferred. Also remove it from the menu to utilize a virtual. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux/linux-ext-ocf-linux.mk')
-rw-r--r--linux/linux-ext-ocf-linux.mk25
1 files changed, 0 insertions, 25 deletions
diff --git a/linux/linux-ext-ocf-linux.mk b/linux/linux-ext-ocf-linux.mk
deleted file mode 100644
index 1a601d58c..000000000
--- a/linux/linux-ext-ocf-linux.mk
+++ /dev/null
@@ -1,25 +0,0 @@
-##################################################
-# Linux OCF extension
-#
-# Patch the linux kernel with OCF
-##################################################
-
-ifeq ($(BR2_LINUX_KERNEL_EXT_OCF_LINUX),y)
-LINUX_DEPENDENCIES += ocf-linux
-
-# Prepare kernel patch
-# The linux-3.2.1.patch is just the main inclusion, most of the code
-# resides in the ocf/ subdir.
-# It works for older kernel versions.
-# Run tested from 2.6.38+ and build tested from 2.6.35+
-define OCF_LINUX_PREPARE_KERNEL
- support/scripts/apply-patches.sh $(LINUX_DIR) \
- $(OCF_LINUX_DIR)/patches/ linux-3.2.1-ocf.patch ; \
- grep -q __mix_pool_bytes $(LINUX_DIR)/drivers/char/random.c && \
- $(SED) 's:wordcount\*4:&, NULL:' $(LINUX_DIR)/drivers/char/random.c ; \
- cp -rf $(OCF_LINUX_DIR)/ocf $(LINUX_DIR)/crypto/ocf ;
-endef
-
-LINUX_PRE_PATCH_HOOKS += OCF_LINUX_PREPARE_KERNEL
-
-endif #BR2_LINUX_EXT_OCF_LINUX